ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

Problem during upgrade of the server, mail not fully restored

I got a problem when trying to upgrade the server where OnlyOffice workspace is installed (Ubuntu 20.04).
I ran apt update and then apt dist-upgrade.
Almost everything went fine, but the process get stuck during the phase "Generating /boot/initrd.img "
And OnlyOffice was not working anymore even after I succeeded in upgrading the server.
Fortunately I had a snapshot of the disk, I could use to restore the previous state. But it was from 12 hours earlier, so some information (the work of yesterday) would be lost.
I thus dumped the mysql data base, restored the disk from the snapshot, and finally restored the mysql database (onlyoffice).
I almost recovered everything. But the mails from yesterday (which are present in the list of mails) open with an error message instead of their content.
My question is. Is there a way to restore the content of these mails. I did not found any database for the mails, nor any data folder.
Thank you,

Hi Rene33,

It seems you restored only records about emails that are contained in the database, but not the emails themselves. They are stored as physical files (along with other portal files) on the server in the directory /var/www/onlyoffice/Data/
For future cases like this, I’d recommend backing up both database and /Data/ directory.

Hi Carl,
Thank you for your answer.
I found the mail bodies.
I tried to manually copy them, but it doesn’t work. I think I should find the mail id for each mail and manually create the folder in the last folder of the mail bodies… but this is too much fastidious.
Next time, I will make a snapshot of my disk just before running the upgrade.
By the way, I don’t know why my ugrapde crashed OnlyOffice.
The behavior was weird : site unreachable, but absolutely nothing in the logs…
Anyway, it works now, but the mail of the 25 of august…
And I have set-up a true automatic backup of the whole server.
Regards,