Printer not listed, only print to file: OnlyOffice Desktopeditors 7.5

Do you want to: Suggest a feature / Report a bug / Ask a how-to question
For feature suggestions, describe the result you would like to achieve in detail.
For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem.
OS version: Ubuntu 22.04.3 LTS
App version:
Downloaded from: ONLYOFFICE website / Other (specify): SNAP on Ubuntu Jammy

The print dialog only gives me the Print to File option. Documentation suggests I set up a printer by tapping the Tools or Settings icon in the right top of the top toolbar. There is no such thing anywhere in my menus.

And when I print my spreadsheet to PDF and print that out, half my numbers are XXXXX no matter how wide I make my cells.

Hello @profe_miguel

As far as I know, snap applications are running in some sort of containers (just like Docker ones) that do not have direct access to the system. Please try granting access to the printers for Desktop Editors by running such command:

sudo snap connect onlyoffice-desktopeditors:cups-control :cups-control

Please let me know if it helps.

Hello. I have the exactly the same problem, with version , under Ubuntu 22.04. I have read on that this was a known bug, and that it is supposed to be fixed in versions 8.0 of OnlyOffice. Unfortunately, it doesn’t seem to be working for me.

sudo snap connect onlyoffice-desktopeditors:cups-control :cups-control
snap “onlyoffice-desktopeditors” has no plug named “cups-control”

I resolved my problem by switching to Linux Mint, but only after making sure I got the Cinnamon (Edge) version, which has the 6.5 kernel which supports my printer, evidently. I don’t know if the kernel was the problem with Ubuntu but I had had so many problems that I hoped a switch would do it. (It mostly has, though Firefox continues to freeze from time to time.)

Hello @ADSensei

Can you provide a link to the mentioned issue on GitHub?

By the way, there is newer version of Desktop Editors is available, please try updating your app and checking the situation afterwards.

Here is the link :
OnlyOffice (snap package) does not find installed printer · Issue #69 · ONLYOFFICE/snap-desktopeditors · GitHub

Thanks for the link.

As I can see, described issue is related to network printers and it was indeed fixed. Once again, newer version 8.0.1 has been released. Does the issue occur on this version?

In general, have you tried installing Desktop Editors from alternative source? You can find all provided sources here:

Thanks for your reply. I have already tried uninstalling, then reinstalling : the problem still occurs.
The version I use is version (snap). Installed from the snapstore under Ubuntu 22.04.1 LTS.

I had the problem which I was able to resolve by unistalling and reinstalling OnlyOffice from the terminal.
My printer a Canon PIXMA MG3070S had to be installed using

Please try alternative installation method, for instance, AppImage or flatpak and let me know.

Allow access to printers: To grant access to printers to an application, you need to add it to the appropriate group. Most Linux distributions use the lpadmin group to access printers.

sudo usermod -aG lpadmin $USER

Hello @gav
Please re-write your post. The official languages of this forum are English and Chinese.

Hello. I had the same issue with OnlyOffice - which I enjoy over LibreOffice. Anyway, I installed OnlyOffice using the CLI +SnapStore at first. I purged the SnapStore install and installed OnlyOffice from Pop!_Shop install flatpak option. My Canon printer shows up now.


I installed OnlyOffice using the CLI +SnapStore at first

Could you please let us know your exact OS version? We will try to check if there’re any issues with this installation type. Do I understand it right that you followed this guide at first? How to install Desktop Editors from snap package? - ONLYOFFICE