Printed documents always UNcollated

Printed documents (PDF and .Docx) come out fine on my workplace’s Xerox printer when I create one single multi-page document. However, when I make multiple copies of a document (say 20 copies for my students), I get the following result: a 20-page stapled bundle of page 1 of the document, a 20-page stapled bundle of page 2 of the document, etc.

I suspect that this is an OnlyOffice error because the following other programs are able to make multiple-copy print jobs without issue:

  • Microsoft Word
  • Chrome/Brave web browser using Google Docs
  • LibreOffice

The workaround I’ve created is to save the document as a PDF and open that PDF in any OTHER software that can view PDFs. Then I’ll print the PDF from there. I’ve tried printing it as a PDF from OnlyOffice and the collation problems persist, even though it prints well with every other program I have on my computer.

I see no options in Onlyoffice’s print dialogue to adjust the collate settings. When I try and print from the system dialogue, it indicates that the document it receives from OnlyOffice is properly collated to create bookets. However, that is not what comes out of the printer.

Hello @JimboJims

Please provide some more additional information:

  • version of ONLYOFFICE Desktop Editors;
  • from which source it was installed;
  • version of used OS;
  • how printer is connected to your device.

In general, does it happen with all multipage documents or a particular one?

Thank you for the reply.

I’ve tried with two version of OnlyOffice:

  1. Desktop Editor Version: version 8.0.1.31 (x64 exe) (has collation issues)
  2. Online interface hosted on your free cloud service (browser used to access is Brave (version 163.169) (collates properly)
  • Desktop Editor Source: Downloaded from your website (ONLYOFFICE desktop and mobile apps | ONLYOFFICE)

  • Version of OS: Windows 11 23H2 (OS build 22631.3235)

  • Device (if relevant): Surface Pro 8 (Intel i5 model)

  • The printer is connected wirelessly to my computer over Wifi. My school uses printer account codes, which I submit through a popup dialogue window after I hit “print” from the printer dialogue window.

  • The printers are Xerox Workcenter 5855 or Xerox AltaLink C8170 models.

I’ve tried many different multi-page documents in various formats (.doc, .docx, .odt, .pdf. This happens in every case. I actually completely reinstalled the OnlyOffice application in the hopes that it would fix things-- it didn’t. I’ve tried printing local files on my computer as well as files I created on the OnlyOffice cloud and the error persists in all cases.

Again, no other program on my computer seems to have the collation issue that OnlyOffice has always given me. I’ve yet to see OnlyOffice collate my documents normally (either through the Desktop editor or the online cloud portal).

May I ask you to provide screenshots of printing windows when printing a document from our editor?

Here is what happens:

Link to photo steps

Can you specify to which solution you are referring? Is it ONLYOFFICE Personal?

Also, I’d like to know if printing scenario is identical when printing from mentioned cloud solution and Desktop Editors and if both are executed from the same device.

Yes, OnlyOffice Personal. When printing from your cloud-based online editor things come out properly. Only the Desktop Editor causes issues (and I’ve re-installed the desktop editor to see if that would fix it, which it does not). In both cases I am using the same computer. We changed the printers last week at our school and even with the new printer model, requiring different drivers, the issues persist.

Thank you for providing requested information. We will run some tests to reproduce the issue and analyze it now. It is possible that more information will be required so I’ll let you know.

We have confirmed the issue with uncollated printing in Desktop Editors. The bug report was registered and we have started working on it. Once it is fixed, I will notify you.

Thank you for reporting this issue.