ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Print preview and orientation issue

Hello Onlyoffice team!

I live in Brazil and I don’t speak English, so this is a Google translation of my Portuguese text, I hope you understand :wink: .

I arrived here a short time ago and I have good expectations, congratulations for the great work :clap: :clap: :clap:.

I know that for most common files it already has compatibility and that’s fantastic, but I’ve encountered some problems with some formatting and routines.

So let’s go in parts, this is my first topic and not to get huge and confusing, I’ll separate a problem for each topic.

In this topic I will deal with worksheets created in MS Office and that behaved differently in Onlyoffice, not that it needs to be the same, but that it becomes a barrier to migration.

Suggestion:
I missed the print preview to identify any formatting errors before printing and have the opportunity to correct them.

Problem:
When printing or saving as, the sheet being in landscape orientation and with the print area defined, the result is a document in portrait orientation, that is, in both processes it is a file that needs to be rotated to the left to actually be in the orientation landscape.

Onlyoffice: Desktop Editors 7.0.1.37
OS: Windows 10 Pro 21H2
Browser Version: Google Chrome 100.0.4896.75

Hello @Marcelo

Preview page before printing exists for docx\pptx files. As for xlsx files (spreadsheets), this feature will be available in v.7.1

As for the second request, we are checking the situation. I will update this post when we get any news.

Hello @Marcelo
We checked provided scenario.
Please pay attention to printer settings. It should be set to landscape too (print scenario).

hello Alexandre

As you can see in Video_1 I use the same configuration and the same file in Excel and everything works as expected, even if you look at video_2 that I made following your orientation, despite being as a portrait, printing from Excel produces a horizontal file as expected, I believe that Excel should send this parameter which overrides that of the printer.

Note that there’s nothing I can do, the page doesn’t come out horizontally, is it something to be corrected or is there something I didn’t see?

Hello @Marcelo
You are right, the described situation was added to internal bug 56646. I mentioned this bug number in your second post, but probably forgot to update this topic too.
We are working on it already. When I have any news about mentioned situations, I will update this post.