Prevent OO from constantly writing stats in postgres DB

I host an instance of OO document server (docker) to connect it to a nextcloud( docker).

It works great and I love OO, my issue is that the document server constantly (every minute) writes into the pg_stats_tmp folder in 3 different files in the postgres docker even if the document server is not in use. I also think it flushes the data every 10min making it’s use questionable to me.

Is there a way to prevent this?
What is it for?

Thank you for your help.

Hello @cupidstunt

Please provide some more information about the request:

  • version of Document Server;
  • screenshot of output of command docker ps;
  • absolute path to the folder pg_stats_tmp;
  • example of content that is written to any file.

Do I understand it correctly that you have PostgreSQL running in separate container?

Hi @Constantine ,

yes, I run OO document server and PostgreSQL in different docker containers.

  • the version is the latest I suppose (I pulled it on Sunday from your dockerhub (should be how can I find it out?

  • screenshot attached

  • /var/lib/docker/overlay2/eefaef499aaeed8b586e9d4cf752cd9c7165214c459c86f7ca19d3ea029f5ca8/merged/run/postgresql/14-main.pg_stat_tmp

  • the files (tested with) db_16384.stat is binary content

The statistic collection is a default process in PostgreSQL, so Document Server does not write any data to those files. More about this process and why it is needed you can find here:

Also, in the article you will find ways to limit gathering of statistics via certain parameters.
However, keep in mind that changing default settings of PostgreSQL is your own risk. We do not recommend performing these actions since we didn’t test the behavior of Document Server in such environment.
If you decide to change any settings please make a backup/snapshot of the server to be able to rollback in case of issues with performance.