Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

Opening documents from Community server not working after update to 7.1 version

Hello, after I updated my community server(docker version) to 7.1 version, I started getting messages about wrong security token whn I trying to open doc file(or any file in online editors).
After some google searching I found out, that version 7.1-2 has “JWT” feature activated by default and I need setup secret somewhere in community server to be abble to open and edit documents. How do I do that?

Hello @OnOoflrFice99
Do I understand it right that you are using Workspace?
First of all, please update your Document server to v.7.2.1 (the latest version). We activated JWT in v.7.2
If the issue still persists after the update, please check local.json file (Document server container:/etc/onlyoffice/documentserver/local.json) and web.appsettings.config file (Community server container: /var/www/onlyoffice/WebStudio/web.appsettings.config).
There’s example from my test server:

As you see, secret and header match on the both sides.
I believe that update process to v.7.2.1 should fix your issue since we put these parameters as docker variables in update scenario. If not, you can change these parameters manually.
If you change it in local.json file, you have to run supervisorctl restart all to accept changes. If you change it in web.appsettings.config, you have to run service monoserve restart.

NB! We strongly recommend to prepare whole server backup before any server side actions (config changes, updates).

Thank you for perfectly formuled answer. After your suggestion about config changes, I can open and edit documents as always.
Just for curiosity, my cfg did look like this, before manual edit:

So, I restarted my virtual server with onlyoffice services and same error is back. After looking at local.json on document server, I see that after restart it has generated new secret and no suprise here, on workspace server in web.appsettings.config it wasnt reflected.

It’s a little bit strange. Would you mind running a test? Please restart your server one more time (whole server, if I understood it right). Will the issue reproduce again?

Indeed, same result after restart:

oo4ed

It’s a little bit strange. Please point me to the guide which you used for Workspace installation. Also let us know exact OS version of your server.

Well, I already move on. Firts, I tryied 6 months old backup and get same failure. Final solution was to delete all docker images, conteiners, volumes etc - just fully clear docker. Then I run workspace…sh script again and installed OO. Because all data are mapped in local folders, recovery was easy-automatic, its just rereads cfg and all was running. Important is that failure was gone after clean install. My hint is that failure was due to some uncovered-unhandled exception in upgrade rutine…it was old installation which was upgraded 10-15x.
So, now its working and lets hope it will continue working without problem.
Anyway, after this expirience, next upgrade of OO will start with snapshot of VM, where it runs.

We are glad that the situation is solved.
Please feel free to contact us if you face similar issue again.