Opening doc/xls files in ONLYOFFICE Docs editor component

Do you want to: Ask a how-to question
Document Server version: 8.0.0-89
Type of installation of the Document Server (docker, deb/rpm, exe): docker
OS: Windows 10
Browser version: Chrome Version 120.0.6099.71

What is supposed to happen when a user opens a doc/xls files using the ONLYOFFICE Docs editor angular component in our application, currently the file is opened normally, they can edit it, but when they try to save the changes, something breaks and the changes are not saved nor is the file converted to any other format.

I do see a message in the documentserver log:

“[admin1] nodeJS - rollback to save changes to ooxml. See assemblyFormatAsOrigin parameter. formatTo=doc”

But changing the assemblyFormatAsOrigin property to false doesn’t seem to do anything.

I am not sure what is suppose to happen, ideally the file would be converted to docx automatically, or a window would pop-up to ask the user to confirm if they want to convert their doc file to docx, is something like this possible ?


Please specify if you are opening .doc files without converting them to OOXML format in advance? ONLYOFFICE Api Documentation - Converting and Downloading File

We strongly recommend to convert legacy formats before opening to avoid such issues.

Please provide us an example of a file with which the issue occured and full Document Server logs (/var/log/onlyoffice/documentserver inside the container), as well as your default.json config (/etc/onlyoffice/documentserver inside the container) with the assemblyFormatAsOrigin parameter settings


Yes, I was directly opening the .doc file in the front-end editor, without starting any conversion, manually.

I “solved” the issue for now by manually sending a request toward the ConvertService.ashx, and converting the doc to docx, then opening it in the editor on the front-end.

I still would have liked if it was possible for that to happen automatically, without me converting the file with help of ConvertService.ashx manually.

But this way is also completely fine and works for my situation.


I understand.
Great to now that the issue’s been resolved, you are welcome.