OO on k8s behind ingress proxy, path redirect issue

Hi guys, I have OO installed on kubernetes with ingress upfront, problem is its now behind a double nginx proxy, I have it currently set as path /onlyoffice and every time I access certain urls, it will rewrite and drop me down to / and break the link

Can someone please advise if its possible to somehow resolve this other than editing the rewrites in OO directly ?

Thank you in advance !

Document Server version: 7.3.3
OS: Kubernetes 1.23
Ingress/nginx: 1.94

Hi @dannik :wave:

Could you please clarify, do you have Ingress behind a proxy or proxy instead of Ingress?

It seems like you need to pass a header.

  • If you’re using Nginx in front of Docs (without Ingress), here’s the configuration.
  • If you’re using Ingress, you need to specify the subpath here .

Please note that Kubernetes cluster is mainly available and tested with Docs Enterprise/Developer since it provides high availability and failover resistance for cases when there is a high number of concurrent connections involved.

Scalability options are available only for commercial licenses. If you have purchased a commercial license, we recommend contacting us via Zendesk.

Also v.7.3 is outdated.
We recommend running update process timely, each new version contains fixes of known bugs and new features.

1 Like

Thank you Nikolas!
Interesting variable path, was not aware of it … is that the new prefix variable in nginx I found in later versions of OO ?

I have OO deployed with its own proxy (nginx) behind k8s native ingress, so my issue is the path is being rewritten by OOs nginx, I can get around it only by modding the nginx config past deployment.

oh I looked at the helm example, well Im not using helm, Im building the deployment and ingress myself, I of course have the path set, but its not working when it hits certain rewrite locations such as:
rewrite ^/OfficeWeb(/apps/.*)$ $the_scheme://$the_host/7.3.3-49/web-apps$1 redirect;

this rewrite will drop the path and go to the root because of how its written, now I can manually add the path in here, but thats a manual post deployment action Id like to avoid
I did see a new feature called $prefix in the newer version, thinking of implementing that and then forwarding it from ingress

Hi @dannik :wave:

For issues regarding cluster installation, we recommend reaching out to support.

I would be glad if our community could assist in resolving your issue.