Onlyoffice Server behind a nginx proxy

Hi All

Have a new install OnlyOffice/Ubuntu22LTS/postgres/Nginx that is behind an Nginx proxy server serving LetsEncypt certs.

I created a subdomain for this server: eg; onlyoffice.mydomain.tld

I believe that I have the proxy is setup correctly to allow OO into the LAN.

I installed OO using the onlyoffice website install guide. I used the proxy nginx conf file from the install guide as well.

But I believe that I am having nginx configuration issues on the OO server.

I have been editing the “/etc/nginx/conf.d/ds.conf” file, I removed all the 443 server block contents, as per the nginx config tester command “systemctl status nginx.service”

Also weird is when I type in “https://onlyoffice.mydomain.tld” in the browser, it redirects to “https://onlyoffice.mydomain.tld/mail

Wondering if anyone has a generic nginx file contents that I can use to populate it and start editing it from there?

Also, if I need to edit other nginx files? I tried editing the default in the sites-available folder, but still no go.

Any other ideas, will be helpful

Cannot find a good answer in the internet searches.


Hello @gegerwccqdedeef

Please see this article from Help Center to find examples of configs for various proxy service that can be used with Document Server:

Hi Constantine

Thank you for your reply,

I did use this config file on the proxy nginx.

I still can’t through proxy from internet.

This is the edits that I did in the proxy https->http config file:

upstream docservice {

## Normal HTTP host
server {
  listen [::]:80 default_server;
  server_tokens off;

  ## Redirects all traffic to the HTTPS host
  return 301 https://$server_name:443$request_uri;

server {
  listen ssl;
  listen [::]:443 ssl default_server;
  server_tokens off;
  root /usr/share/nginx/html;

  ## Strong SSL Security
  #ssl on;
  ssl_certificate /etc/letsencrypt/live/;
  ssl_certificate_key /etc/letsencrypt/live/;
  ssl_verify_client off;


  ssl_protocols  TLSv1.1 TLSv1.2 TLSv1.3;
  ssl_session_cache  builtin:1000  shared:SSL:10m;

Is this correct?


If your goal is to set up https to http proxy, please refer to this config:


Yes I know that is the file,

Can you please see if the edits to the file in my second post is correct?


As I can see many parameters from mentioned proxy-https-to-http.conf are missing. There are commented out notes in the config that tell which parameters to change in order to make it work.

Please use whole config for your scenario with proper changes.

If you require deep analysis of your issue, please visit this thread: