Onlyoffice portal never starts properly

I have an older server running Ubuntu 18.04.06 and an enterprise server with version 11.X which expired at the end of 2021. The server has been running fine for years and never had an issue. 2 days ago I had to reboot the server, which is a VM and has docker running all the containers for the enterprise version. The server now only ever spins at the web portal wit the following:

The portal start up process might take some time, please wait…
Please do not reload the page or shut down your computer.
We are working on it.

I am able to log into the docker containers and services, but systemctl complains its not running on the community server container.

I’m looking to get some help on this to figure out how to get the server and services back up and running again so I can access the files.

Thank you.

Hi @dthompson , please execute docker exec -it onlyoffice-community-server service monoserve status
If the service is down, restart it with docker exec -it onlyoffice-community-server service monoserve restart

Hi, thanks for the reply.

When I try that command, I get the following error:

docker exec -it onlyoffice-community-server service monoserve status

monoserve: unrecognized service

Have you tried restarting the Community Server container with docker restart onlyoffice-community-server?

I have yes and it provides the same result.

EDIT: I should also edit that if I run this command, I get the following from the docker host:

docker exec -it onlyoffice-community-server systemctl status monoserve

System has not been booted with systemd as init system (PID 1). Can’t operate.

Please check if systemd is running in the container
docker exec -it onlyoffice-community-server service systemd status

docker exec -it onlyoffice-community-server service systemd status

systemd: unrecognized service

Does not appear to.

Please specify the currently installed version of the Community Server.

Here is what I’m seeing from a docker ps request:

d7ce55f3d860 onlyoffice/documentserver-ee: “/app/ds/run-documen…” 20 months ago Up 21 hours 80/tcp, 443/tcp onlyoffice-document-server
9d64d7c0b062 onlyoffice/communityserver: “/app/run-community-…” 22 months ago Up 57 minutes>80/tcp,>443/tcp, 3306/tcp, 5280/tcp, 9865-9866/tcp, 9871/tcp, 9882/tcp,>5222/tcp, 9888/tcp onlyoffice-community-server
935f949e4c12 onlyoffice/controlpanel: “/var/www/onlyoffice…” 22 months ago Up 21 hours 80/tcp, 443/tcp onlyoffice-control-panel
4cb1a7c45362 mysql:5.7.20 “docker-entrypoint.s…” 5 years ago Up 21 hours 3306/tcp onlyoffice-mysql-server

Please try reinstalling the Community Server following these steps:

  1. Create a snapshot of the server to be able to rollback if something goes wrong.
  2. Execute docker stop 9d => docker rm 9d
  3. bash -u true -cv -ids false -icp false -ims false
  4. Check if the portal can be opened now.

I now get this error that the community server isn’t installed:

bash -u true -cv -ids false -icp false -ims false

Install with Docker [Y/N/C]? y

5.5: Pulling from library/mysql

743f2d6c1f65: Pull complete


385b8f96a9ba: Pull complete

Digest: sha256:12da85ab88aedfdf39455872fb044f607c32fdc233cd59f1d26769fbf439b045

Status: Downloaded newer image for mysql:5.5

ONLYOFFICE MYSQL SERVER is already installed.


7.16.3: Pulling from onlyoffice/elasticsearch

ea362f368469: Pull complete


0f68d14d3575: Pull complete

Digest: sha256:f09d622776b02012dbc8d63493e9bafac29cd03c2716f364262c15e3622ceda1

Status: Downloaded newer image for onlyoffice/elasticsearch:7.16.3


unknown flag: --cgroupns


It seems that reinstalling this way will not work due to an old version of ONLYOFFICE components you were using. Please restore the server snapshot to proceed with the troubleshooting.

Even though this is a rather old thread, I stumbled across the same problem on Ubuntu 18.04 trying to upgrade a very old version of Onlyoffice.

The “unknown flag: --cgroupns” error is due to an old docker version that will not be upgraded on ubuntu 18.04 unless the new dependencies will be deployed. So

sudo apt update && sudo apt full-upgrade

is necessary and this fixed this issue for me.

1 Like