ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

OnlyOffice overwrites characters from keyboard

I’d like to Report a bug (or Ask a how-to question)

Hello, I have system keyboard (Input source) with national characters “Polish - Pro”. Normally I’m getting national characters with Alt. Especially “ę” is Alt-e and “ć” is Alt-c. Unfortunately Onlyoffice overwrites characters from system with its own shortcuts/characters, which are “€” for Alt-e and “©” for Alt-c.
I can’t find a way to change this behaviour, which make Onlyoffice seriously impaired tool in Poland.

OS version: macOS 11.6
App version: 6.4.1
Downloaded from: ONLYOFFICE website

Hello,

Thank you for contacting us!

We will forward the question to the development department and answer you later.

Hello,

This is a recurring problem in the Desktop Editors for macOS.

The issue has been registered in our bug tracking system (bug #49036).

We are sorry for the inconveniences caused.

Best regards,

Thank you. Is there a possible workaround for non-pure-english keyboard users?

Regret to say but as for now there is no any alternative solution for this issue.
We can only suggest using another editor, if the problem does not repeat there, and copying the text to the ONLYOFFICE Documents Editor.

Best regards,

Thank you. What is possible timeframe for correcting this error, which would enable more production-like usage of the OnlyOffice? This error is unfortunately disqualification for us :frowning: [with regards to your achievements in other areas and possibilities which are astounding]
Best,
Marcin

We understand the inconvenience this situation may cause, but, unfortunately, we cannot provide any specific dates regarding the matter.