ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Onlyoffice nextcloud

Report a bug
Everytime I open any doc in nextcloud through onlyoffice, this warning message appears:

An error occurred while saving the file. Please use the ‘Download as’ option to save the file to your computer hard drive or try again later.

I’m using nextcloud (23.0.0) in a docker container with the app OnlyOffice (7.0.1), and in another docker container I have the OnlyOffice documentserver (7.0.1), and they comunicate through nginx proxy manager, the connection works, I can create, edit and save files without losses or problems, but everytime I open a file it says that warning.

Here is my logfile: Nextcloud

I think it has to do with the node modules.

I hope you could help me please

Greetings!

Could you please specify exactly what ONLYOFFICE product is your “OnlyOffice (7.0.1) app”, what guide did you follow when connecting your Document Server to Nextcloud, and what guides did you use to switch your Document Server to HTTPS (If you did that)?

Also - please provide us with all the logs located in the following folder: /var/log/onlyoffice/documentserver/ folder (inside the Document Server docker container) and a screenshot of your Nextcloud’s settings => ONLYOFFICE page.

Best regards.

Sure!

_About the OnlyOffice app, it was version 7.3.0, and I meant it’s the app of OnlyOffice inside nextcloud, sorry if misunderstood before.

_I did not follow a specific guide, I just tried to make it work after watching several videos an reading online. Here is what I did:
First I create a docker container based on this stack:

version: '3'
services:
  onlyoffice:
    image: onlyoffice/documentserver:7.0.1
    container_name: of_onlyoffice
    restart: always
    volumes:
      - of_data:/var/www/onlyoffice/Data
      - of_lib:/var/lib/onlyoffice
      - of_logs:/var/log/onlyoffice
      - of_db:/var/lib/postgresql
      - of_fonts:/usr/share/fonts/truetype/custom
      - of_redis:/var/lib/redis
      - of_rabbitmq:/var/lib/rabbitmq
    expose:
      - "80"
    environment:
      - JWT_ENABLED=$JWT_ENABLED
      - JWT_SECRET=$JWT_SECRET
      
volumes:
  of_data: {}
  of_lib: {}
  of_logs: {}
  of_db: {}
  of_fonts: {}
  of_redis: {}
  of_rabbitmq: {}

Then, when it was running through nginx proxy manager (npm) as “docs.stiv.solutions” using Let’s Encrypt - Cloudflare SSL Certificate to add the HTTPS on that subdomain. I went to nextcloud and set the OnlyOffice Server as follows:
Link of ONLYOFFICE Docs: https://docs.stiv.solutions/
Secret Key: the same credential used in the docker stack “JWT_SECRET”

It worked just fine, but the only problem is the warning message that I mentioned before.

_And here is a folder with all the logs: Nextcloud

Could you please check if your Document Server example (you can check your ONLYOFFICE Docs Community Edition page for instructions on activating and accessing it) is working as intended?

If the example works as intended and you use a proxy server for your Document Server - please refer to the following guide for instructions on setting it up: https://github.com/ONLYOFFICE/document-server-proxy/tree/master/nginx

Best regards

I already checked the Document Server example, and read the instructions for the Github page you sent me, but either way, it keeps showing the same warning over and over again, don’t you know if there is a way to avoid showing that warning somehow?

Please specify if the same error is displayed when using the Document Server example. If it does - please provide us with a screenshot of the error in your example with the address visible.

Best regards.

The Document Server example worked well without error, the error message I see is only when using Nextcloud, but the error is just a warning because, even though it appears, everything works perfect, the files are editable and I can save them on nextcloud, it’s just the message that appears every time I open any document on nextcloud using onlyoffice.

Then the problem is in the settings of your proxy server. Please make sure you’ve set it up according to one of the instructions listed here document-server-proxy/nginx at master · ONLYOFFICE/document-server-proxy · GitHub .

Best regards