OnlyOffice keeps crashing after opening in Nobara 38


I’m using Nobara 38 (based on Fedora) with KDE and installed OnlyOffice (Flatpak version) from the Discover page. When I open the app, it stays open for about 10 seconds and then closes on its own.

I tried uninstalling, removing user data and reinstalling but it didn’t work.

When I first installed it, I got a popup from KDE saying that it’s running in the background, which I didn’t take any action on. I got the same popup when running Nextcloud, another Flatpak, and clicked on Learn More and allowed to run it. I didn’t do that for OnlyOffice.

For those 10 or so seconds, the app is functioning normally and I don’t see any other issues. I have no idea why it’s crashing. Or if it’s being interrupted by KDE somehow.

Below is the neofetch output of my system and a recording of what’s happening–
OS: Nobara Linux 38 (KDE Plasma) x86_64
Kernel: 6.5.9-200.fsync.fc38.x86_64
Packages: 2796 (rpm), 6 (flatpak)
Shell: bash 5.2.15
Resolution: 1920x1080
DE: Plasma 5.27.8
WM: kwin
Theme: [Plasma], Breeze [GTK2/3]
Icons: [Plasma], breeze-dark [GTK2/3]
Terminal: konsole
CPU: AMD Ryzen 5 3600 (12) @ 3.600GHz
GPU: AMD ATI Radeon RX 6600/6600 XT/6600M
Memory: 2770MiB / 15898MiB

Thank you.

Hello @tukykarmakar

First of all, there is newer version of the app available to download. Please try updating or installing actual version to check the situation again.

If issue still persists, you can try installing Desktop Editors with, for instance, snap or AppImage: ONLYOFFICE desktop and mobile apps | ONLYOFFICE

Hi @Constantine

I already updated to the newer version 7.5 after posting here. But I still uninstalled and reinstalled from Discover and it’s still behaving the same. I also tried the Flatpak Official Flathub (user) version and met with the same problem.

I checked the link you provided and downloaded the Flatpak from Flathub, same issue. I installed using the flatpak command with and without higher privileges and had the same issue in both cases.

Finally, I downloaded the AppImage and executed it and it finally stays open. But I don’t see it installed anywhere. I pinned the app to the taskbar after executing the AppImage and tried to run from the pinned icon, but I get the error message saying that the app doesn’t exist where it was.

Am I missing something regarding the installation? It seems like the Flatpak is not working at all and the AppImage is not installing it, only running it with temporary files. Seems strange as almost all other apps in my system are Flatpaks and none of them had any issues.

That’s indeed very strange behavior. As I can see, Nobara also supports snap packages as installation method for apps. Please try also installing snap version of Desktop Editors according to this guide:

I am looking forward to your feedback.

I finally fixed it after a lot of troubleshooting.

I ran flatpak permissions to check the permissions of the installed apps. I noticed that even if OnlyOffice is not installed, the entry for the app remained as below–

background background                           org.onlyoffice.desktopeditors         no          0x00

I ran the command below to allow the background permission–

flatpak permission-set background background org.onlyoffice.desktopeditors yes

Finally, I reinstalled the app and it stays open and runs properly. Note: adding sudo before the commands didn’t make any changes to the permissions in my case.

I suspect this is an issue with KDE. KDE blocks background permissions of Flatpaks by default and gives a popup for users to enable it. If you read the first post, you’ll see that I ignored the popup, because it doesn’t mention the consequences of inaction. But I couldn’t find any option to enable it from KDE’s Flatpak Permission Settings page. I also tried using Flatseal, but it’s not running and giving the error message Failed to start 'Flatseal': execve: No such file or directory.

If KDE is not going to provide the options to change this setting later, then I don’t think they should make such changes at all. I’m fairly technical and can tinker around, but any user that’s not so knowledgeable will be absolutely frustrated. Enabling Snaps is also not an ideal solution as installation of Flatpak and AppImage was done entirely through GUI, and a regular user might not be comfortable to work in the Terminal for Snaps.

I hope OnlyOffice and KDE devs are able to work together and improve this situation. Thanks for looking into my issue.