ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

Onlyoffice groups docker clean install - Unknown upload error

I installed Onlyoffice Groups using the bash script.
I’m uploading the file it says unknown error.

No logs are shown for community server

Obviously you left something out in the installation instructions.

Can you help me?

Hello @abelncm

Please provide us some more information:

  • installation type (Docker, DEB/RPM packages);
  • OS type of host server;
  • a screenshot with the error from inteface;
  • log files located in /var/logs/onlyoffice/communityserver (same path in Docker container) after reproducing the issue.

Additionally, please point me to the guide that you’ve used to install ONLYOFFICE Groups.

Looking forward to your reply.

I used the official guide: Installing ONLYOFFICE Groups for Docker on a local server - ONLYOFFICE

Installing ONLYOFFICE Groups using script => Step 1 and Step 2

  • installation type: Docker
  • OS: Ubuntu 22.10 (Desktop);

Screenshot from GUI: (Just a simple “Unknown Error”)

I can access the logs at my host machine: /app/onlyoffice/CommuniServer

nginx.access.log
ngins.error.log
nginx.apisystem.access.log
nginx.apisystem.error.log

but there’s no error!

I tried change the permissions for the folder app/onlyoffice but with no effect

I was using “localhost” in the url, I changed it to my public IP and it worked.

Now i’m having another problem. Onlyoffice Docs now uses Jwt and a secret, I disabled it because i was getting an error in Onlyoffice Groups saying the token was invalid when opening a file in the editor.

After disabling the JWT for Docs, I now get the error: The document could not be saved, please check connection settings. And I am getting this in the console:

[2023-01-24T00:18:22.274] [ERROR] [localhost] [63vTV8EM_sP7Je9Q0yXPN1AuG5M_HqW_dfbDkaj8ocE_] [e6bffc75-9b2b-11ed-8e6c-0242ac120002] nodeJS - error downloadFile:url=http://192.168.195.92:80/Products/Files/HttpHandlers/filehandler.ashx?action=stream&fileid=9&stream_auth=412215499311.LPZYWKNPSRZFDEKVNOANSMHF3ZGWTFKNAD3K5JA6K&X-REWRITER-URL=http%3a%2f%2f192.168.195.92%3a80;attempt=3;code:undefined;connect:undefined Error: Error response: statusCode:403; headers:{“server”:“nginx/1.22.0”,“date”:“Tue, 24 Jan 2023 00:18:22 GMT”,“content-type”:“text/html; charset=utf-8”,“content-length”:“57”,“connection”:“keep-alive”,“x-aspnet-version”:“4.0.30319”,“cache-control”:“private”};
at Request.fResponse (/snapshot/server/build/server/Common/sources/utils.js)
at Request.emit (events.js:400:28)
at Request.onRequestResponse (/snapshot/server/build/server/Common/node_modules/request/request.js:1059:10)
at ClientRequest.emit (events.js:400:28)
at HTTPParser.parserOnIncomingClient (_http_client.js:647:27)
at HTTPParser.parserOnHeadersComplete (_http_common.js:127:17)
at Socket.socketOnData (_http_client.js:515:22)
at Socket.emit (events.js:400:28)
at addChunk (internal/streams/readable.js:293:12)
at readableAddChunk (internal/streams/readable.js:267:9)
at Socket.Readable.push (internal/streams/readable.js:206:10)
at TCP.onStreamRead (internal/stream_base_commons.js:188:23)

Looks like a 403 error, a permission one! Any ideas?

Most certainly 403 is related to the JWT Token on the Community Server side. I would not recommend disabling JWT Token since it provides a security of your connection and prevents data from being fetched by unauthorized users.

To configure JWT Token on both sides please follow next instruction:

  1. Locate next config var/www/onlyoffice/WebStudio/web.appsettings.config in the Community Server container (use docker ps to see the list of currently running containers and docker exec -it <ID> bash where <ID> is the ID of the container to connect to it);
  2. In the web.appsettings.config locate next strings:
  <add key="files.docservice.secret" value="<your_secret>" />
  <add key="files.docservice.secret.header" value="<your_header>" />

and copy somewhere values <your_secret> and <your_header>.

  1. Connect to Document Server container and open next config /etc/onlyoffice/documentserver/local.json;
  2. In local.json find next section:
      "token": {
        "enable": {
          "request": {
            "inbox": true,
            "outbox": true
          },
          "browser": true
        },
        "inbox": {
          "header": "<your_header>",
          "inBody": false
        },
        "outbox": {
          "header": "<your_header>",
          "inBody": false
        }
      },
      "secret": {
        "inbox": {
          "string": "<your_secret>"
        },
        "outbox": {
          "string": "<your_secret>"
        },
        "session": {
          "string": "<your_secret>"

and set inbox, outbox and browser values to true as it shown above to make sure that JWT is enabled and paste <your_secret> and <your_header> from web.appsettings.config to the string and header strings according to the example above.

  1. Restart Document Server services with supervisorctl restart all to apply these changes and try editing documents again.

Basically, you have to make sure that <your_secret> and <your_header> are corresponding in both configs.

Let me know if you face any difficulties.

The OnlyOffice Docs already comes with the same configuration as the one you gave me at /etc/onlyoffice/documentserver/local.json

Now the one at the Community Server after changing the values you said, and restart the Community container it goes back to its previous default settings.

I’m restarting because without restarting the issue persists.

This is what I have in web.appsettings.config

<add key="files.docservice.secret" value="pGA1SkPJv6xh" />
<add key="files.docservice.secret.header" value="AuthorizationJwt" />

I suppose the header value should be “AuthorizationJ” only? Without the jwt?

Please share the content of local.json in PM.

I don’t mind sharing it here. I’m running it on my localhost

{
  "services": {
    "CoAuthoring": {
      "sql": {
        "type": "postgres",
        "dbHost": "localhost",
        "dbPort": "5432",
        "dbName": "onlyoffice",
        "dbUser": "onlyoffice",
        "dbPass": "onlyoffice"
      },
      "token": {
        "enable": {
          "request": {
            "inbox": true,
            "outbox": true
          },
          "browser": true
        },
        "inbox": {
          "header": "Authorization",
          "inBody": false
        },
        "outbox": {
          "header": "Authorization",
          "inBody": false
        }
      },
      "secret": {
        "inbox": {
          "string": "PCvdQTZ1ZLSxplLmDDSN"
        },
        "outbox": {
          "string": "PCvdQTZ1ZLSxplLmDDSN"
        },
        "session": {
          "string": "PCvdQTZ1ZLSxplLmDDSN"
        }
      }
    }
  },
  "rabbitmq": {
    "url": "amqp://guest:guest@localhost"
  },
  "storage": {
    "fs": {
      "secretString": "SniPvzcofywBOvp7aNtY"
    }
  }
}

If you want to get data from local.json and use it in web.appsettings.config then:

  1. Paste token secret and header from local.json in web.appsettings.config like this:
  <add key="files.docservice.secret" value="PCvdQTZ1ZLSxplLmDDSN" />
  <add key="files.docservice.secret.header" value="Authorization" />

and save the changes;

  1. After that do not restart Community Server container. Instead, restart your portal with systemctl restart monoserve command from Community Server container to apply these changes.

After that try opening the file again.

1 Like

I managed to make it work, following this documentation: Connecting ONLYOFFICE Docs to ONLYOFFICE Groups - ONLYOFFICE

You were leading me at the right direction :slight_smile:

Thank you very much for guiding me

1 Like

Glad to hear that the issue is solved.
Feel free to contact us if you face any other issues.

1 Like

Just so I let everyone who comes after me know, the web.appsettings.config file from Community Server, I altered these lines:

<add key="files.docservice.secret" value="PCvdQTZ1ZLSxplLmDDSN" />
<add key="files.docservice.secret.header" value="Authorization" />
<add key="files.docservice.url.public" value="http://192.168.195.92:88/" />
<add key="files.docservice.url.internal" value="http://192.168.195.92:88/" />
<add key="files.docservice.url.portal" value="http://192.168.195.92/" />

These IP are from my localhost, my network public IP (in linux you find it by the terminal command: ifconfig)

  • I then restarted the monoservice
  • Then deleted something from mysql

According to the link: Connecting ONLYOFFICE Docs to ONLYOFFICE Groups - ONLYOFFICE

All this was done in Community Server container