ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Onlyoffice group shows "Docbuilder url: download" when setting document service address

Pls help on below issue:
After installed the mysql5.6/commutity server(latest)/control panel(latest)/document_server(latest) docker versions, after I set the document service address and click save, it reports “Docbuilder url: download” message. It will pop up a “download failed” error window each time when I try to edit a document.

Those containers are installed on a centos7 server with kernal version as 3.160.0-1062, no internet access.

Browser is Chrome90.0.4430.93.

Hello @xiaojiang.chen
Please point me to the guide which you used for installation. If you looked for installation of all mentioned components on the one server then Workspace guides are the best solution:

https://helpcenter.onlyoffice.com/installation/workspace-install-docker.aspx

https://helpcenter.onlyoffice.com/installation/workspace-install-linux.aspx

These guides are ‘out-of-the-box’ solution, so no additional document service settings are necessary.

But if you are using separate installation (Document server is installed on different server), then please reproduce the issue and make screenshot of an error (also let me know version of all installed components and guide which you used).

Hi Alex,

I didn’t use the installation script. I followed the manual steps in below guide to finish my installation. I’ll try the setup guides you provided.

https://helpcenter.onlyoffice.com/installation/workspace-install-docker-integrated.aspx

doc-server, community-server, mysql and control-panel containers are all in the same linux server without internet access. I want to co-edit the doc, but the doc file will be always downloaded instead of being editted when clicking it If I didn’t set the document service address. If I set the document service address (like: http://172.18.16.154:8000), the warning msg “Docbuilder url: download” shows up when click save, and “downloaded failed” error popped up when I tried to edit a doc file.

Another question: Is the internet access necessary if I want the co-editing feature? My setup is inside the LAN without internet. Also, does the installation script rely on the internet to make the installation?

Thanks,

John

Please go to your portal > Settings > Document Service > click Save button and make a screenshot of the whole page with an error.

Also go to the host and show us output result of these commands:
docker ps
docker network inspect onlyoffice

As for your questions:

the internet access necessary if I want the co-editing feature?

No, if all your users have access to your portal in your local network, then everything should work properly.

does the installation script rely on the internet to make the installation?

Yes, guides which I posted earlier require Internet.

Much appreciated Alex. Issue is fixed.
I reinstalled all the containers with the script you posted and leave the document service settings default. It works fine now.

I missed “-e DOCUMENT_SERVER_PORT_80_TCP_ADDR=onlyoffice-document-server” parameter when I installed doc-server container by manual, which caused the problem in this ticket.

Thanks again for your help.

1 Like