"ONLYOFFICE DocSpace cannot be reached" connector to WordPress

I am trying to integrate ONLYOFFICE DocSpace into WordPress website using the ONLYDOFFICE DocSpace connector.
referring to your page:
Embed documents and folders into your WordPress website using the ONLYOFFICE DocSpace connector
after all things installed, in the configuration page, I input my OODS server url, but:

ONLYOFFICE DocSpace can not be reached

The WP server and OODS server are both online internet, the two servers can visit each other ip and url, their URL are


welcome to have a look at them!

I have added a public room on my OODS site here:

both WP and OODS sites are ok and online internet, but in the initialization settings for the connector, I don’t know, why it can not reach the OODS URL?

Hello @VincentYoung

Please try specifying DocSpace Service Address parameter as http://3.memyselfandi.xyz/.

I have tried that, the same error

ONLYOFFICE DocSpace cannot be reached.

I have deployed another server of Drupal, and installed the connector between Drupal and ONLYOFFICE DocSpace server, and in the configuration page, again, the same error:

I have also tried input of http://3.memyselfandi.xyz, https://3.memyselfandi.xyz and https://www.3.memyselfandi.xyz, all the same error
The login input is my ONLYOFFICE DocSpace website’s administrator account and its password.
btw, the Drupal site for the testing is here
both the Drupal and the WordPress site connector to my OODS server “can not be reached”, so, something wrong with my OODS?
My ONLYOFFICE DocSpace can be connected with any browser and ONLYOFFICE desktop editor, both via http and https, I can’t find anything wrong in these servers

Let’s focus on main topic with WordPress plugin. Please specify versions of DocSpace, WordPress and WordPress plugin - I can see versions in your other thread about fatal error but it seems that there is another environment, is that correct?

They are two different topics

In that topic, all are installed on virtual box and vmware in my home PCs.

But in this topic, all are deployed on internet VPS, so, you can open all the URLs in this topic,

The ONLYOFFICE DocSpace Server version on the
is 2.5.0

The WordPress Server version on the
is 6.5.2

And the connector version 2.0

Please try additionally specifying DocSpace Service Address with dash on the end and https, e.g. like https://www.3.memyselfandi.xyz/.

If it does not connect, please let me know OS types and versions of servers where DocSpace and WordPress are installed.

I got a new error information:
res.response.domains is not iterable
with the address:

My DocSpace Server V2.5 information:
Fedora OS with the uname command output here:

[root@2024-04-28-220312-SaoPaolo-OODS ~]# uname -a
Linux 2024-04-28-220312-SaoPaolo-OODS 6.8.5-201.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Thu Apr 11 18:25:26 UTC 2024 x86_64 GNU/Linux
[root@2024-04-28-220312-SaoPaolo-OODS ~]#

and DocSpace Server is installed via Docker mode

My WordPress Server V6.5.2 information:
Ubuntu OS with the uname command output here:

root@2024-04-25-Miami-WordPress-Test:~# uname -a
Linux 2024-04-25-Miami-WordPress-Test 5.15.0-102-generic #112-Ubuntu SMP Tue Mar 5 16:50:32 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux
root@2024-04-25-Miami-WordPress-Test:~# /opt/vultr/version.sh
'OS: 22.04.4 LTS (Jammy Jellyfish)', 'Wordpress: 6.5.2'

and WordPress Server is pre-installed by the VPS provider vultr, detail information here:
Vultr WordPress Details

Just to make sure that both servers are mutually available please execute wget <address>
from each server to another and provide outputs.

Here come:

wget from DS server to WP server:


wget from WP server to DS server:

I don’t know why there is an error of no certificate for the 3.memyselfandi.xyz, so I tried the www.3.memyselfandi.xyz and the 3.memyselfandi.xyz with –no-check-certificate parameter
the later two got the same index.html file, I paste the content to here because .html file is not allowed to upload here

<!doctype html><html lang="en" translate="no"><head><meta charset="utf-8"/><meta name="viewport" content="width=device-width,initial-scale=1,shrink-to-fit=no,user-scalable=no,viewport-fit=cover"/><meta name="theme-color" content="#000000"/><meta name="google" content="notranslate"/><link id="favicon" rel="icon" type="image/x-icon" href="/logo.ashx?logotype=3"/><link rel="mask-icon" href="/logo.ashx?logotype=3"/><link rel="manifest" href="/manifest.json"/><meta name="react-apple-itunes-app" content="app-id=944896972"/><meta name="react-google-play-app" content="app-id=com.onlyoffice.documents"/><style>body {
        height: 100%;
        margin: 0;
        padding: 0;
        width: 100%;
        font-family: "Open Sans", sans-serif;
        font-size: 13px;
        -webkit-font-smoothing: antialiased;
      }</style><title>ONLYOFFICE</title><base href="/"><script defer="defer" src="static/js/main.a50472b9a0a972cd28bb.bundle.js"></script><script defer="defer" src="remoteEntry.js"></script></head><body ondragstart="return false"><noscript>You need to enable JavaScript to run this app.</noscript><div id="root"></div><script src="/static/scripts/browserDetector.js?hash=0b5923e3cb00b1e2a7ad7d72a72b1a4b"></script><script>console.log("It's WEB CLIENT INIT");
        .then((response) => {
          if (!response.ok) {
            throw new Error("HTTP error " + response.status);
          return response.json();
        .then((config) => {
          window.DocSpaceConfig = {

          if (
            window.navigator.userAgent.includes("ZoomWebKit") ||
          ) {
            window.DocSpaceConfig.editor = {
              openOnNewPage: false,
              requestClose: true,

          //console.log({ DocSpaceConfig: window.DocSpaceConfig });
        .catch((e) => {
          window.DocSpaceConfig = {
            errorOnLoad: e,

and the index.html page loaded in browser shows nothing:

I checked again my settings in the DocSpace server, noticed that I have switched on the configured domain:

should I switch it off?

Thanks for letting me know about that. For now can you try specifying IP address of your DocSpace server with http as DocSpace Service Address for test purposes?

the same error:

ONLYOFFICE DocSpace cannot be reached.

btw, I found another thing, my browser can not load the ONLYOFFICE DocSpace page with the ip input the url bar:

It’s blank

Only url www.3.memyselfandi.xyz will make my browser load my ONLYOFFICE DocSpace page correctly

Is it related to this trouble?

Finally, I made it!

Here, in my OO DS Server, I enter the addresses of my WordPress server and of my Drupal server to the allow list, then, back to my connector initial setting pages in WP server and Drupal server, input my OO server domain https://www.3.memyselfandi.xyz and site master’s account name and password, and save, they will success go to the next step.

what step I missed to do is the allow list in the OO server settings page, and this information is not covered in your manual here:
Embed documents and folders into your WordPress website using the ONLYOFFICE DocSpace connector

Thank you for the help all this thread of post!

1 Like

Good job! I’m glad to know that you’ve managed to find the solution. Also thanks for providing this information, it’d be useful for others too.