Onlyoffice closes as soon as it starts

I’m having problems with onlyoffice on my KDE Neon.
I tested installer.DEB, flatpack, Snap and Appimage. In all cases, onlyoffice simply closes as soon as it starts, the app window appears but then closes without any error warning.
System: KDE neon 6.0.5
Kernel: 6.5.0-35-generic (64-bit)

Error captured via terminal using Appimage:

./DesktopEditors: /tmp/.mount_DesktojeeEve/usr/bin/libselinux.so.1: no version information available (required by /lib/x86_64-linux-gnu/libgio-2.0.so.0)
./DesktopEditors: /tmp/.mount_DesktojeeEve/usr/bin/libselinux.so.1: no version information available (required by /lib/x86_64-linux-gnu/libmount.so.1)
Qt: Session management error: None of the authentication protocols specified are supported
/tmp/.mount_DesktojeeEve/usr/bin/editors_helper: /tmp/.mount_DesktojeeEve/usr/bin/libselinux.so.1: no version information available (required by /lib/x86_64-linux-gnu/libgio-2.0.so. 0)
/tmp/.mount_DesktojeeEve/usr/bin/editors_helper: /tmp/.mount_DesktojeeEve/usr/bin/libselinux.so.1: no version information available (required by /lib/x86_64-linux-gnu/libmount.so.1)
/tmp/.mount_DesktojeeEve/usr/bin/editors_helper: /tmp/.mount_DesktojeeEve/usr/bin/libselinux.so.1: no version information available (required by /lib/x86_64-linux-gnu/libgio-2.0.so. 0)
/tmp/.mount_DesktojeeEve/usr/bin/editors_helper: /tmp/.mount_DesktojeeEve/usr/bin/libselinux.so.1: no version information available (required by /lib/x86_64-linux-gnu/libmount.so.1)
QXcbConnection: XCB error: 8 (BadMatch), sequence: 806, resource id: 94371903, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 824, resource id: 94371903, major code: 130 (Unknown), minor code: 3
/tmp/.mount_DesktojeeEve/usr/bin/editors_helper: /tmp/.mount_DesktojeeEve/usr/bin/libselinux.so.1: no version information available (required by /lib/x86_64-linux-gnu/libgio-2.0.so. 0)
/tmp/.mount_DesktojeeEve/usr/bin/editors_helper: /tmp/.mount_DesktojeeEve/usr/bin/libselinux.so.1: no version information available (required by /lib/x86_64-linux-gnu/libmount.so.1)
QObject::~QObject: Timers cannot be stopped from another thread
Segmentation fault

Hi @lotustech :hugs:

Thank you for providing the necessary information.
We will investigate this behavior on the OS you specified. :handshake:

I installed the new version 8.1 of the .DEB package, the opening and closing error continues.
Error logo:
QXcbConnection: XCB error: 8 (BadMatch), sequence: 807, resource id: 96469055, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 825, resource id: 96469055, major code: 130 (Unknown), minor code: 3

any alternative? I can’t use onlyoffice in any way.

@lotustech
What graphics card or integrated GPU are you using?
Are you using Wayland protocol? (It might be causing some issues.)

Does the problem persist if you switch to X11?

I’m using an Nvidia 150M on Kade Neon with Plasma 6.1 based on Ubuntu 22.04lts. I don’t use Wayland, I’m using X11.

1 Like

@lotustech :wave:

We tested the system installation on an i5-10600K with Intel UHD Graphics 630 and could not reproduce the issue on KDE Neon 6.0 (KDE Plasma version 6.1.0) with both Wayland and X11.

  1. Let’s start by diagnosing what happens during the program launch (using the ONLYOFFICE Desktop Editors package (.deb) ):
    Run the following command and send us the resulting file strace_(date).log:

    strace desktopeditors &> strace_$(date +'%Y-%m-%d_%H-%M-%S').log
    
  2. Please specify your monitor model, its resolution, and whether you have any custom scaling or xrandr settings in place.

I did as you suggested, installed the .deb package and started it with the command.

As for the second question, I use a Dell notebook 14" 8th gen i5 processor, 16gb of ram, 1tb nvme SSD. Running on X11, on wayland the same problem happens. I use an nvidia MX150 hybrid on demand.

Below link to the log file.

Thank you for the information! :hugs:

We need some time to analyze the issue. As soon as we have more details or additional questions, I’ll get back to you.

Hello, let’s proceed with the following steps:

It appears that you are using an account named lotustech.

  1. Please provide the output of the following commands to check permissions:

    ls -la /home/lotustech/.config/onlyoffice/
    ls -la /home/lotustech/.local/share/onlyoffice/
    

  1. Delete the configuration directories:

    rm -rf /home/lotustech/.config/onlyoffice/
    rm -rf /home/lotustech/.local/share/onlyoffice/
    
  2. Try opening the OnlyOffice desktop editors again.


  1. Create a new user and attempt to open the editor under the new user:

    You can create a user via terminal:

    useradd testuser -d /home/testuser -m -G users -s /bin/bash
    passwd testuser
    

    Alternatively, you can use a graphical interface to create the user.

  2. After creating the user, log in through the graphical interface as testuser and try to open the OnlyOffice desktop
    editors.