Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Onlyoffice cannot be reached please contact admin

ONLYOFFICE cloud: Personal
Do you want to: Ask a how-to question
Browser version: Safari 13.1.3

Hi there !
I’m facing a problem. I have nextcloud installed on apache server. Then I installed documentServer and nginx listening on port 81. I’m using the recommended host to proxy NC and DS.
I can check connect DS with nextcloud:


But when I open a document, I got a popup like this one : (see next msg)

Any idea ?
Thanks in advance.

1 Like

Here the popup :

Hello @hauhazice
Please, wait until the issue is reproducible and open the browser console (F12 in Google Chrome). Please check if there are any error entries in the ‘Console’ and ‘Network’ tabs. Please make screenshots.

I found out a fix. I switched back to http 1.1 and it works fine.
Now I have an other issue, I can open a doc but it is never saved. The only error that I found is the following, in web socket dialog : Error on save server subscription.
Any idea ?
Thanks in advance.

Hi again,
After more research, I found this error in docservice logs :

[ERROR] nodeJS - postData error: docId = 3285794835;url = https://<my-domain>/index.php/apps/onlyoffice/track?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJ1c2VySWQiOiJuaWNvbGFzIiwib3duZXJJZCI6Im5pY29sYXMiLCJmaWxlSWQiOjIxOSwiZmlsZVBhdGgiOiJcL3Rlc3QuZG9jeCIsInNoYXJlVG9rZW4iOm51bGwsImFjdGlvbiI6InRyYWNrIn0.nn5ZvQyNanMobrICOQMkf6eNfLELbatT94hdoCGpvdU;data = {"key":"3285794835","status":1,"users":["oc03gtni0nzl_nicolas"],"actions":[{"type":1,"userid":"oc03gtni0nzl_nicolas"}]}
Error: Error response: statusCode:403; headers:{"date":"Wed, 24 Aug 2022 12:23:41 GMT","server":"Apache/2.4.38 (Debian)","expires":"Thu, 19 Nov 1981 08:52:00 GMT","pragma":"no-cache","cache-control":"no-cache, no-store, must-revalidate","x-request-id":"8USNNKJuOoR5OfFRgSwu","content-security-policy":"default-src 'none';base-uri 'none';manifest-src 'self';frame-ancestors 'none'","feature-policy":"autoplay 'none';camera 'none';fullscreen 'none';geolocation 'none';microphone 'none';payment 'none'","x-robots-tag":"none","set-cookie":["oc_sessionPassphrase=VPJAc0h39juA3iGb8NTNMxhMt30JlGBIUN562NjmWWj16PWxBLdVEO15DgtvRb1sBZ0mCyh4qWBJsHQGV9UTJrP9E%2BoQhUjCdcOK6mJayoNIY8MsxYNSjIa2KI2hB4Ly; path=/; secure; HttpOnly; SameSite=Lax","oc03gtni0nzl=nf1n388emqqgp6g5nq921uesou; path=/; secure; HttpOnly; SameSite=Lax","__Host-nc_sameSiteCookielax=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=lax","__Host-nc_sameSiteCookiestrict=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=strict"],"strict-transport-security":"15552000","referrer-policy":"no-referrer","x-content-type-options":"nosniff","x-frame-options":"SAMEORIGIN","x-permitted-cross-domain-policies":"none","x-xss-protection":"1; mode=block","content-length":"27","keep-alive":"timeout=5, max=100","connection":"Keep-Alive","content-type":"application/json; charset=utf-8"}; body:
{"message":"Access denied"}
    at Request._callback (/snapshot/server/build/server/Common/sources/utils.js)
    at Request.callback (/snapshot/server/build/server/Common/node_modules/request/request.js:185:22)
    at Request.emit (events.js:400:28)
    at Request.<anonymous> (/snapshot/server/build/server/Common/node_modules/request/request.js:1154:10)
    at Request.emit (events.js:400:28)
    at IncomingMessage.<anonymous> (/snapshot/server/build/server/Common/node_modules/request/request.js:1076:12)
    at Object.onceWrapper (events.js:519:28)
    at IncomingMessage.emit (events.js:412:35)
    at endReadableNT (internal/streams/readable.js:1317:12)
    at processTicksAndRejections (internal/process/task_queues.js:82:21)

Something got my attention : "expires":"Thu, 19 Nov 1981 08:52:00 GMT"

(I replaced my domain for security reasons)

Hello,
Looks like you have an issue with JWT. Please send me a screenshot of your ONLYOFFICE Connector settings page and your local.json file it is located in this path: /etc/onlyoffice/documentserver/local.json (You can send a PM for your safety).

Did not find where to send PM ! Here my local.json file :

{
  "services": {
    "CoAuthoring": {
      "sql": {
        "type": "postgres",
        "dbHost": "localhost",
        "dbPort": "5432",
        "dbName": "onlyoffice",
        "dbUser": "onlyoffice",
        "dbPass": "*********"
      },
      "token": {
        "enable": {
          "request": {
            "inbox": false,
            "outbox": false
          },
          "browser": false
        },
        "inbox": {
          "header": "Authorization"
        },
        "outbox": {
          "header": "Authorization"
        }
      },
      "secret": {
        "inbox": {
          "string": "sdANDisIticEiAlE"
        },
        "outbox": {
          "string": "sdANDisIticEiAlE"
        },
        "session": {
          "string": "sdANDisIticEiAlE"
        }
      }
    }
  },
  "rabbitmq": {
    "url": "amqp://guest:guest@localhost"
  }
}

I removed sensitive information such as token value and password.

Please, click on my avatar and select “message” and send me the screenshot of ONLYOFFICE Connector settings page from your Nextcloud.

My bad, I found the trick : token was not enabled in local.json file. Thanks you.
I was wondering, what is the purpose of those 2 fields :


I let them blank and it is working fine.

PS : I don’t have a link called “message” when I click on your avatar.

Hello, you can see the description of these options here -

https://helpcenter.onlyoffice.com/integration/gettingstarted-nextcloud.aspx#Configure_block

https://api.onlyoffice.com/editors/nextcloud#settings