ONLYOFFICE - Bad Gateway behind NginxProxyManager

I have set up ONLYOFFICE on a Debian 11 VM.

When I enter the IP all fine:

But when I enter my domain.
BAD Gateway.

I have an IONOS subdomain: [onlyoffice.mydomain

At IONOS I point This domain to my [Myfritz.domain with CNAME
So the domain onlyoffice.mydomain. Arrives at my FritzBox(router)
I have a NPM running and point the domain to the VMs IP address with the ONLYOFFICE server.

When I enter the IP of the VM, ONLYOFFICE server Page is shown.

But when I put in The onlyoffice.mydomain.
I get: Bad Gateway

In NPM I have a let’s encrypt certificate!

What Have I done wrong??

Hello @Witzker,
For the Document Server to work correctly behind a nginx proxy, the configuration must be set up according to our examples:

Unfortunately, we have no experience with Nginx Proxy Manager so you can look for a way to import a custom config to it.

I’m a newbie, so I choose the widely used NPM to have simple configuration with GUI.

I found this, but - No plan How-to.

So pls help how to get this running?

Please provide screenshots of your Proxy host settings for the Document Server in Nginx Proxy Manager.

Many THX for taking care:

Now I have :slight_smile:
and is working now!
Before I had here https:// and 443.

But in Nextcloud I get.
Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.) (version

Please attach the log file /var/log/onlyoffice/documentserver/converter/out.log so I could check the issue.