OnlyOffice 7.3 (.3.49) Error 403 Forbidden

I am using Owncloud Enterprise 10.12.0 with the new OO Connector 7.8.1.
OO V (Docker) without JWT works flawless.
I updated the oo docker container to onlyoffice/documentserver-ee:latest
which is version 7.33.49. When i try to save the oo-server settings in the owncloud
connector window the error occurs:

The jwt_header and jwt_secret in the docker-compose.yml are identical to the ones in the
config.php of the Owncloud.

If i comment out the 403 message in the ds-docservice.conf i can save the oo settings.

#if ($secure_link = “”) {
#return 403;

When i try to open a document now the OnlyOffice comes up but throws a timeout after a while saying:

The connection to the server has been interrupted. Please reload the page. …

But of course that doesn’t help.

Any idea?

I had the same error but with Nextcloud, I posted about how I solved it in this thread, perhaps that solution will also help in your case.

Hello @Ingo

Please uncomment these lines, then execute script bash /usr/bin/ and check the situation again.

Hallo @chris, thank you for you replay. I tried your advice but it doesn’t fix the problem.

1 Like

Hello @constantine, i stumbled over this one too, sadly it doesn’t help either.
I digged through nearly everthing google could find, and i also read probaly everthing that
is findable here on this forum. It must be some really weird thing.
The hint is probably the commented part: $secure_link must be empty, but why?

Hello @Ingo

Please check if token credentials are correct in local.json config from /etc/onlyoffice/documentserver/.
Additionally, please share with us your .yml file and log files of Document Server from /var/log/onlyoffice/documentserver/ for analysis. You can send them to me directly via PM.

Hi @Constantine, here are the files you requested:


Thanks for the info.
Please also provide logs of Document Server after attempting to connect,. As I can see you even have log folder mounted to the host.

Also, I’ve just noted that you are starting an Enterprise Edition container. Does it mean that you have a valid license?

Hello @Constantine, yes i have valid license file, and sadly there is no log entry from the event of connecting from owncloud that produces the 403 forbidden error.

Hello @Ingo

If you have valid license, then I’d recommend contacting us via Zendesk to get prompt replies:

Hello @Constantine, thanks, i will do that.

1 Like


For the rest of you, Support sorted it out:

i had a local directory of the nginx_includes, because we enabled the license info page for
some internel subnets. Problem was that those include files where not the right ones
for the actual container. I copied the ones from the container, put them to the local
directory, modified the allow rules for our internal subnets, started the container and
now everthings works as it is supposed to do.

Big thanx to @Constantine again :slight_smile:

1 Like

Hello @Ingo

I’m glad that we’ve managed this problem out.

1 Like