Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Old version Enterpris with DocServer 6.0 for Docker, installation

Dear ONLYOFFICE specialists
Is there a way to get an older version for Docker installation as a link in the download area?
My problem is as follows: I have a Windows-based version as an enterprice (license) and for technical reasons I have to switch to Debian-Docker. I tried to install via link, but I get the latest version of the document server and I don’t have a license for it. I need to switch my running portal to docker and need your help! Thank you very much for the answer and possible help with a link to version 6.

Hello @Prof_h_c_K_Krause
You can switch repo manually when container is being created. Please check it out, this is –ee (Enterprise Edition) repo: Docker Hub
So, for example, for v.6.0.1.32 installation you should run the same steps as described here https://helpcenter.onlyoffice.com/installation/docs-enterprise-install-docker.aspx
But change the repo in the end of the command.
Example:

sudo docker run -i -t -d -p 80:80 --restart=always \
    -v /app/onlyoffice/DocumentServer/logs:/var/log/onlyoffice  \
    -v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data  \
    -v /app/onlyoffice/DocumentServer/lib:/var/lib/onlyoffice \
    -v /app/onlyoffice/DocumentServer/db:/var/lib/postgresql  onlyoffice/documentserver-ee:6.0.1.32

Alexandre, Many many thanks! I just have to read the installation instructions, sorry I’m stupid. It is actually possible to select the versions to install.

Unfortunately simply switching from/to 6 version with command didn’t work. Tried few times: ended up Community Server not being able to properly communicate with DocServer. Next- I do a clean install with version default.

As far as I understand, you need to migrate portal (Workspace) from Windows server to Linux\docker one.
Please try to follow my steps:
First of all, your new portal must have the same component versions as the old one. For example, if old portal had Community server v.10.5, then you should install the same version on the new server.

The point is that different versions of a product may have different versions of database tables.

You can deploy docker containers with not actual versions via installation script workspace-enterprise-install.sh .

Component version parameters you can find here: Installing server version with additional script parameters - ONLYOFFICE

Example of the command: bash workspace-enterprise-install.sh -ims false -cv 11.1.0.1506 -cpv 2.9.1.369 -dv 6.3.0.11

You can find component versions here:

Community Server: Docker Hub

Control Panel: Docker Hub

Document Server: Docker Hub

When new portal installation is done, let’s start the migration process. Prepare backup file via Control Panel on the old server > change core.machinekey parameter on the new server as it is described here:Using the Control Panel backup/restore feature - ONLYOFFICE > restore backup file on the new portal.

If I misunderstood your request, please clarify it.

Dear Alexandre, Everything is correct. I have the task of switching from Windows server 2019 to Linux/ Docker. I will follow your advice and do it step by step. If something doesn’t work out, I will ask questions. Thanks again.

1 Like

Dear Akexandre hello
After a long time waiting for problem solving with Windows version I have 2nd attempt to install the older component on Docker. I installed versions you recommended on fresh machine Ubuntu (v-24, latest) with Docker. But when starting there is an error in ngnx.error.log. Error looks like this:

2022/08/12 08:57:45 [crit] 785#785: *370 connect() to unix:/var/run/onlyoffice/onlyoffice.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.1.15, server: , request: “GET /api/2.0/capabilities.json HTTP/1.1”, upstream: “fastcgi://unix:/var/run/onlyoffice/onlyoffice.socket:”, host: “192.168.1.25”, referrer: “http://192.168.1.25/

2022/08/12 08:59:03 [error] 785#785: *382 connect() to unix:/var/run/onlyoffice/onlyoffice.socket failed (11: Resource temporarily unavailable) while connecting to upstream, client: 127.0.0.1, server: , request: “GET /api/2.0/capabilities.json HTTP/1.1”, upstream: “fastcgi://unix:/var/run/onlyoffice/onlyoffice.socket:”, host: “127.0.0.1”

2022/08/12 08:59:13 [error] 785#785: *378 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 192.168.1.15, server: , request: “GET /api/2.0/capabilities.json HTTP/1.1”, upstream: “fastcgi://unix:/var/run/onlyoffice/onlyoffice.socket:”, host: “192.168.1.25”, referrer: “http://192.168.1.25/

Please what can I do about it? Installed Docker containers:

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
b09e4a793a43 onlyoffice/communityserver:11.1.0.1506 “/app/run-community-…” 58 minutes ago Up 34 minutes 0.0.0.0:80->80/tcp, :::80->80/tcp, 0.0.0.0:443->443/tcp, :::443->443/tcp, 3306/tcp, 5280/tcp, 9865-9866/tcp, 9871/tcp, 9882/tcp, 0.0.0.0:5222->5222/tcp, :::5222->5222/tcp, 9888/tcp onlyoffice-community-server
c0fca4b4ff7e onlyoffice/controlpanel:2.9.1.369 “/var/www/onlyoffice…” 59 minutes ago Up 34 minutes 80/tcp, 443/tcp, 9833-9834/tcp onlyoffice-control-panel
0f5ddf5c1453 onlyoffice/documentserver-ee:6.3.1.32 “/app/ds/run-documen…” 59 minutes ago Up 34 minutes 80/tcp, 443/tcp onlyoffice-document-server
4aec5d09f6ac onlyoffice/elasticsearch:7.16.3 “/bin/tini – /usr/l…” 59 minutes ago Up 34 minutes 9200/tcp, 9300/tcp onlyoffice-elasticsearch
f1ef469694cd mysql:8.0.29 “docker-entrypoint.s…” About an hour ago Up 34 minutes 3306/tcp, 33060/tcp onlyoffice-mysql-server

Thank you, Konstantin
P.S.
When installing Document Server version 6.3.0.11, Docker did not find it, which is why I installed my current version 6.3.1.32, could it be because of that?
After successful start I try to restore my backup from Windows version.

Hello @Prof_h_c_K_Krause
Sorry for the late reply. Mentioned error entry is probably related to Mono service. Could you please run a test? Please go to Community server container > service monoserve restart > re-check the result.
Do I understand it right that you see 502 error in the browser after clean docker installation?
One more thing. The main point of migration process between servers is the same component versions on the both sides. So, if you have Community server v.11.1 on your windows server, so you have to install the same version for Linux machine (same for other components)