"no such file or the directory" while installing the doc space server

I’m installing the doc space server now.
OS: Deepin Linux, all information in this snapshot:

I’m installing the doc space community version guided by this page

And I am stuck in this snapshot

I don’t know where the install-Docker.sh and install-Debian.sh files are located, and Why they were lost during the installation.

Also, I have tried OpenEuler Linux and the same error, maybe nothing error with the OS I have. Is it the script? or the internet connection? or anything others?

Hello @VincentYoung
It seems that you have no rights on the catalog where you performed this action. The another thought that something wrong with your Internet connection and script cannot get ONLYOFFICE repositories to download install-Docker.sh and install-Debian.sh scripts.
Please check out your right on ‘Downloads’ folder and make sure that there’s no any proxy in front of your server that can interrupt the situation.

I sudo in every step and have enough power to do anything.
I didn’t configure any proxy in front of my server, but, you know, GFW is a variable in the process, as you can see in my snapshot, the file docspace-install.sh can be downloaded to my server, but the install-Debian.sh and install-Docker.sh, cannot be downloaded, where are they stored on the internet? Could I download them by myself?

I think I have found the answer already.
I opened the docspace-install.sh file in VS code on my Windows PC, and found all the source URLs of the missing files:


After this, I copied these URLs into my Firefox browser, The URL can not be found:

then, I enabled my V2RayNG software


to be able to visit Google, YouTube, Twitter, and so on, foreign websites, then, I succeeded in downloading all these files!
So, the answer is, these 3 files are different from the docspace-install.sh file, they are located on a server whose IP is on the list of GFW of PRC. I don’t know, How could you solve this little trouble.

Btw, after this, I continued to install DocSpace, but, come to another trouble here:

Again, I look into this .sh file code line 96, But I cannot find anything wrong. So, what is this problem?

Another way, I found your GitHub page:

I downloaded the latest release, but there isn’t a help file for installation from the source code, how to do this?

but the install-Debian.sh and install-Docker.sh, cannot be downloaded, where are they stored on the internet?

these scripts are located here: https://github.com/ONLYOFFICE/DocSpace/tree/master/build/install/OneClickInstall
The main script that you have run is trying to download one of them, depending on installation way. Please check out that this repository is available from your server. Please let us know the result.
As far as I understand the entire situation is related to GFW.

P.S. Please check out https://helpdesk.onlyoffice.com/hc/en-us and your email. I have started discussion there.