ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

Nextcloud/Owncloud to Docker OnlyOffice

I am having an issue with onlyoffice/documentserver:latest from DockerHub. I am trying to get a remote project of mine launched as a demo for my Masters in Information technology. I have a Windows VMware VM running Ubuntu 20 and the exact setup on my home lab. On my remote server, I have NextCloud loaded and decided to get Docker with Portainer a go. I loaded up onlyoffice and troubleshot getting SSL to work through a different port.

The Remote Ubuntu server has Apache2 running Nextcloud (bare, not Docker) and Docker running Portainer and DocumentServer. I got everything running and was able to proxy the docker container and change port 80 to 8081 after getting SSL certs. I changed to 433 and to 8443. I can access the subdomain to that server with no issues, and I get the “true” statement for the health check.

I CAN (could) NOT get Nextcloud to connect to Onlyoffice Document Server (running on the remote server) to accept any subdomain or internal IP version, no matter what block I put the server info in. The connector has the option for advanced settings with internal information. That didn’t work. I tried changing the config.php for Nextcloud with all the different combos I found with Google…

I even tried adding the subdomain as a trusted side, adding the JWL and the
“‘onlyoffice’ => array ( ‘verify_peer_off’ =>TRUE, ),”

Nothing works, so this leads to why I brought up my home lab. I decided to install a fresh instance of Nextcloud on there and give it a go. Shoot the same version and everything using VMware Ubuntu Server, same PHP versions, everything. I pointed to the sub-domain of my remote server, and bam, it connected, and I could edit documents… This tells me my proxy config in apache2 is working, and the container works, but Nextcloud locally on the remote server will not work. I also tried the Owncloud side loaded to Nextcloud on the remote server to see if it was Nextcloud, and nope, it wont connect either.

SOLUTION FOUND WHILE WRITING!

I checked admin>logging and found a weird error about index.php not being able to access .ocdata file. Re-did chown and chmod with no success.

REMOVED Nextcloud folder (remember this is Apache2 install). I used latest.zip from GitHub.
Unzipped new Nextcloud install with the same name (so I didn’t have to modify my Apache2 Proxy). This is a fresh-ish install. I connected it to the same database, but it went through the setup page again. Once logged in, I reinstalled the connector and put in everything for the docker container via my subdomain and it started working.

Theory - something got screwed up in my Remote Nextcloud install; the Fresh install on my home server worked, but I wasn’t getting the same errors. Note my remote Ubuntu VM with Nextcloud is only a week old with no one using it. I thought that since it was a recent install with nothing in it, I would just try to see what a fresh install would do. Fixed.

I can’t replicate the result - a fresh install after the docker install seems to have worked. I thought I would still share for documentation, which may help someone else.

Document Server version: onlyoffice/documentserver:latest.
Connector version: Nextcloud connector 7.6.8
DMS (platform) version: Nextcloud 25.0.1
OS: Ubuntu Server 20 and 22
Browser version: Chrome/Firefox
Attach logs if possible.

Hello @v3rb

I’m not sure where the problem was coming from but certainly glad that you’ve managed it by yourself. Indeed this might be useful for someone.
Let us know if you face any other difficulties.