Nextcloud - after update OnlyOffice to v7.9.0 files are saved, not opened any more


I’m using OnlyOffice in Nextcloud v25.0.8 as SNAP install in Ubutu v22.0. It is a VM under control of Hyper-V in a Microsoft enviroment and as a reverse proxy I’m using IIS.

With the last version (unfortunetly, I can’t tell the last version number) of OnlyOffice everything worked great: In Nextcloud i’ve clicked on a word file and it immedeately opened in OnlyOffice so I was able to modify the docx file in a browser.

However, after upgrading to OnlyOffice v7.9.0 the files I’m clicking on are not opened anymore. Instead, Nextcloud is only offering to save the docx files.

Collabora Office & Nextcloud Office are deactivated.

I’ve tried to remove and reinstall OnlyOffice but not success: clicking on a docx file I only can save, not open it anymore.

What can I do? Is there an option to downgrade OnlyOffice to the last working version?

Has anybody an idea what I can do to use OnlyOffice again to open office files in a browser with nextcloud?

Greeting from Hannover,



I’ve played around - it seams OnlyOffice v7.9.0 has problems with my reverse proxy configuration (the prior version, however, had not).

When I go in Nextcloud to administrative-settings/OnlyOffice, I find the box “the address of ONLYOFFICE Docs” with the ling to my server:


When I click on “save” the error message appears:

Error when connecting (cURL error 7: Failed to connect to port 443: Connection refused (see hs:// for hs://

So it seams to me that something was modified in OnlyOffice v7.9.0 compared to the last version I’ve succesfully used (v7.8.0 ?) regarding the reverse proxy issue.

What can I do?


Hello @hanneshar
I believe we have to start with Document server logs and general information about your installation:

  • Please let us know the exact version of your Document server.
  • reproduce the situation (go to connector page and click Save button) and make screenshot of entire page with the result.
  • when the situation is reproduced, please provide us with whole Document server logs folder. It’s located here:
    docker: /app/onlyoffice/DocumentServer/logs/documentserver/
    deb\rpm: /var/log/onlyoffice/documentserver/
    Windows: Program Files\ONLYOFFICE\DocumentServer\log

Hallo Alxandre,

thank you for your help.

Because I’ve needed Nextcloud and OnlyOffice for my daily work this week I’ve disconnected the direct access of the VM with NC & OO by my DSL router and restored a backup with OO v7.8.0. This way I’ again able to use OO successfully at first because my reverese proxy is accessing the VM.

Next time I will find time to play with the VM will be the weekend. Then I will make a new backup and install again OO v7.9.0 in order to generate the data you are asking for.

However: is there an option to prevent an automatic update of the OO v.7.8.0 app in NC so I can remove the internet block in my router to gain access to the VM again? As far as I see even NC v27 sill works with OO v7.8.0.

Greetings from Hannover/Germany,


Hello @hanneshar

Nextcloud 27 is compatible with connector app of version 8 or higher. You can check out it here:

1 Like

Hello @hanneshar
Constantine is correct, please use the correct connector app version and let us know the result.