Nextcloud 28.05 onlyoffice plugin 9.2.0 bug

You can see here:

Is there someone who cares about?
In my opinion this is a genearal issue, but seems to me none cares.

Hello @caustic
Please describe the situation as detailed as possible. When did the issue arise? Was it after a clean installation or after performing some actions such as updating.
Additionally, please provide us with the following information:

  1. Versions of Document Server, connector app, Nextcloud.
  2. Please reproduce the situation and make a screenshot of an error itself.
  3. Please provide us with Document server and Nextcloud logs.
1 Like

We have had exactly the same problems since the update to 9.2.0.
Managed Nextcloud at Hetzner (StorageShare)

The problem is that the save button is inactive and you cannot save the entries in the app configuration in the Nextlod app.

The save button is without function, so we cannot edit and save the address of ONLYOFFICE Docs.

NextCloud Version: 28.0.3
OnlyOffice Version: 9.2.0

Hello @Florian
Thank you for the provided data!
Could you please make screenshots of entire connector page? We need to take a look at your connector settings.

Hello @Alexandre
Thank you for your enquiry.
I have already posted a screenshot of the Konnector settings, here is another screenshot of all the settings for this point.

However, the problem is more likely to be that we cannot save the settings. The save button has no function. Various JavaScript errors are displayed on the page as already mentioned before.

I have made the address of ONLYOFFICE Docs unrecognisable for the screenshot, as I can’t save it anyway.

We use StorageShare with Nextcloud 28.0.3 from Hetzner and the “ONLYOFFICE Docs Community Edition 9.2.0.” on a cloud server at Hetzner.

Thank you for quick reply. Could you please show us the list of installed apps (plugins) on the Nextcloud side?
Also, please disable > remove > re-install our connector app. Will the situation reproduce again?

We have already reinstalled the OnlyOffice app several times without success.

Could you please run a test? Please disable and remove the connector app one more time. After that please install and enable it via terminal. Please follow my steps:

sudo -u www-data php /var/www/html/nextcloud/occ app:install onlyoffice
sudo -u www-data php /var/www/html/nextcloud/occ app:enable onlyoffice
sudo -u www-data php /var/www/html/nextcloud/occ config:app:set onlyoffice jwt_secret --value=YOUR_SECRET
sudo -u www-data php /var/www/html/nextcloud/occ config:app:set onlyoffice DocumentServerUrl --value="https://DS_ADDRESS/"

One more thing. Could you please check browser console (F12 in Google Chrome) while you’re opening the connector page and clickin Save button? Please show us any error entries from Console and Network tabs.

Hello @Alexandre
I see exactly what has already been mentioned here:

I will try out the lines about the terminal, thank you. I’ll get back to you.

Unfortunately, I cannot execute the commands on Hetzner’s Nextcloud server. They are not made available to me there.

Understood, we are continuing our checks. I will keep you posted.

I tried the installation via command line, the complete plugin 9.2.0 is not working.

Hello @caustic and @Florian
We have prepared test build of the connector app for Nextcloud v.29: Artifact · ONLYOFFICE/onlyoffice-nextcloud@e4f9234 · GitHub
Could you please install it and check the situation? You need to disable and remove current connector app and after that install the test build manually: ONLYOFFICE Api Documentation - Nextcloud ONLYOFFICE integration app
After that clear browser cache and check the situation.

Enabling the app “Collaborative tags” fixes it for me.

Update: the fix is planned for the next version of the connector app.