ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

New File does not create from the create button

Community Server/Control Panel version: 12.1.1194
Type of installation of Workspace (docker, deb/rpm, exe): exe
OS: Windows Server 2016
Browser version: Firefox 109.0 (64-bit)

Whenever I create a new file of any type, I get this issue and file does not get created, nor opens for editing:


2023-03-05 05:51:35,923 ERROR [49] localhost - ASC - System.IO.DirectoryNotFoundException: Directory 'C:\RANK_EXPERIMENT_3\BASE\App_Data\static\partnerdata' not found
   at ASC.Data.Storage.DiscStorage.DiscDataStore.DeleteFiles(String domain, String folderPath, String pattern, Boolean recursive)
   at ASC.Data.Storage.BaseStorage.DeleteFiles(String folderPath, String pattern, Boolean recursive)
   at ASC.Web.Core.WhiteLabel.TenantWhiteLabelSettings.RestoreDefault(Int32 tenantId, IDataStore storage)

The folder exists however:

This behaviour only happens when I create a file from the button on top left corner. Uploaded files are normal.

I tried building from sourece code and had build issues

Even though I had only made UI changes, now however I tried building again from original source code and the issue fixed, but still has my UI changes, strange.


Hello @OnlyOfficeTester
Do I understand it right that the issue is resolved already? But now you face an issue with UI changes?
Did you compile Groups on the same server as previous portal?
Please note if you changed anything in the source code, we can’t provide support, because we can’t predict possible issues of your changes.

As far as I understand, html/css changes shouldn’t bother but while building from source code it says WebDav.svc.dll not found

Issue is not really resolved I just copy pasted files which were missing

I expect not to have these kind of issue if I am building source code without any change to it

It’s a little bit strange. Please point me to the guide which you used. Also please clarify if you compiled Document server too or used .exe installation file.

Building from the current Source code using this link: Compiling ONLYOFFICE Groups for a local server - ONLYOFFICE

and in the deployed WebStudio\Products\Files\DocStore folder is completely empty. I don’t think this is my environment’s issue since I tried to repoduce and same output on another device as well.

We’re checking the situation. I will update this thread when we have something to share.

Hello @OnlyOfficeTester
We have checked the situation, you’re right, the compilation scenario isn’t complete. We moved file samples to separate repository So you can download it to web/studio/ASC.Web.Studio/Products/Files/DocStore/. The other way is to clone this repository and run this command
git submodule update --init --recursive

We thank you for pointing us to this situation. We’re going to rewrite Compiling guide.

1 Like