ONLYOFFICE DocSpace released: improve document collaboration with offices, customers, and partners. Use it for free!
ONLYOFFICE DocSpace released

Mailbox Creation Error

Control Panel:
Community Server:
Document Server:
Mail Server: 1.6.75

Everything was working fine, until today - I can’t create mailboxes. I get this error:

where to look for error logs, specifically on mailbox creation errors? Thank you.

Hello @rodster

Could you please try to restart the Mail Server container and check the situation after that?
If it reproduces, please provide next information:

  • execute docker logs onlyoffice-mail-server and provide the output;
  • logs of Community Server from /app/onlyoffice/CommunityServer/logs.

You can upload the output and the logs to the portal in an archive and share an external link to it (do it via PM in terms of safety).

hi @Constantine , both logs uploaded and a link has been sent via pm.

Thank you for the logs and output. I’m analyzing it.

1 Like

Hello @rodster

From logs it look like Mail Server settings are incorrect. Please check them in Settings > Integration > Mail Server. Check if the Mail Server address is correct, make a screenshot of the page once Save button is pressed.

Hi @Constantine. thank you for checking the logs. Here’s the integration-mail server screen. the Save button is disabled:

note that we didn’t set these settings, it was automatically set during installation. Also, we’re previously able to create and remove accounts - this was working before. Furthermore, despite that we’re unable to add new accounts, we’re able to send and receive emails. all emails are still flowing in and out.

is there anything I should change from these settings? thank you.

Please try connecting, will it allow you to do it?

when I click connect, i get this:image

@Constantine I’m able to resolve this but I’m not sure if the steps are correct:

  1. first is i determined the IP address of the onlyoffice-mysql-server container via:
    sudo docker inspect onlyoffice-mysql-server | grep “IPAddress”
  2. based on the result, I updated the “mail server database host” ip address on the integration-mail server screen.

it now allows me to connect and save. Also, I’m now able to create new mailboxes.
Favor to confirm if the steps are correct? and do I need to do this everytime the creation fails? thank you.

As it stated on the last screenshot, the issue was in the database address and you have resolved it by using a correct address so these steps are indeed correct.
However, I’m not sure why it was changed and resulted in the incorrect settings in general. Possibly if there was a server/portal reboot performed, it resulted in reverting Mail Server settings to the default state. Make sure to save current settings by pressing the Save button after successfully connecting to the server.

1 Like

thank you @Constantine. what’s strange is that it stopped all of a sudden that we cannot create new mailbox - we were able to create and remove mailboxes before. So as the IP address change - I don’t know how this could’ve happened by itself. also strange is that inbound and outbound emails are still working and never stopped. anyway, this is another knowledgebase entry I need to keep and to remember when this happens again in the future. thank you so much!

If I’m correct, address container address can change after a reboot/restart.

Receiving and sending the mail is the functionality of Mail Aggregator that is a part of the Community Server.

You can also try connecting your Mail Server by the names of the Docker containers:

  • for Mail Server http://onlyoffice-mail-server/;
  • for MySQL Server http://onlyoffice-mysql-server/.

Thank you @Constantine. If the “address container address can change after a reboot/restart” - does that mean the email creation will eventually still fail? meaning, we need to set again the Settings-Integration-MailServer-Mail Server DatabaseHost everytime we reboot the server?

if that’s the case, is there a way for the Settings-Integration-MailServer-Mail Server DatabaseHost to be set automatically to the IP of the database everytime we restart?


You can try connecting via container name, it doesn’t change so after reboot it should be fine.

1 Like

it works! alrighty. thank you @Constantine. I learned so much about this.

1 Like

So now it does not really matter what IP container has, even after reboot it will be able to connect.

I’m glad to help. Thanks for your patience.

1 Like