ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

Mail sending but not receiving

Hello, since I read some of the previus discussions here my context:

Installed Community Server (running community Mail Server: mail.bemeda.ch) on a VS, all dockerised, following these instructions:
https://helpcenter.onlyoffice.com/installation/workspace-install-docker-integrated.aspx

VS is running an Ubuntu 20.04.1 LTS (GNU/Linux 5.4.0-47-generic x86_64)
and docker is: Docker version 20.10.21, build baeda1f

Hier my Mail logs : http://46.231.204.15:8080/d/3a1a1dd6927d40fa98a4/

Any help is much appreciated! Thanks!

Opend Ports on Ubuntu VS using : sudo ufw allow for 465, 993, 995 which seem to be closed
and rules are added but nothin listens to those.
Restarted everything and did
service onlyofficeMailAggregator restart
inside the onnlyoffice-community-server but still the same issue : (

Hier the whole community-server logs:
http://46.231.204.15:8080/d/6c2d7dc9efbc4e2094d4/

tried sudo ufw disable
restart all
still doesnt work
then sudo ufw enable :nerd_face:

External Mail client can send and receive, but not the Onlyoffice one which still only sends … What could cause this? How could I troubleshoot? What would you try?

Hello @fradarr
Thank you for provided logs.
Is the issue related to all mail accounts on your portal?
Please go to Control Panel > Update > make screenshot of this page.

Hello Alexandre,
Thanks for your reply, unfortunately my VS collapsed (first time see) and going back to backup versions just reproduced the crash. So I’m got them (service provider) to make a fresh install and I’m starting all over again.
P.S. I remember that Control Panel > Update gave that it’s not possible to find out the actual versions and that in might hang with the docker version, but the docker version was the latest.

Now I’m trying to do the same install walking through the same intallation guide, will surely end up with the same issues. Will post them here.

Thanks for your support!

P.S. I run this VS
Hardware-Spezifikationen … : 4 Cores, 8GB RAM, 50GB SSD
And the docker stats used to show some huge % usage rates, it might be the thing that killed it :man_shrugging:

So same place again with same problems as after the first installation:
(usage rates seem ok this time)

  1. mail sending but not receiving incomming mail

  2. can’t access documents getting the “security token” issue (only workaround I found here is accessing the docker container and setting security token to false in *.json)

And the control panel update looks the same as before:

Docker version is 20.10.21

Mail is full functional. Opend the ports by searching the “Service Name and Transport Protocol Port Number Registry” with this command:

cat /etc/services | grep service-name

and then open the ports missing from this:

https://helpcenter.onlyoffice.com/installation/mail-open-ports.aspx

with this command:

sudo ufw allow servicename

Then restarted the service like this:

docker ps - check Community server ID
docker exec -it ID bash
service onlyofficeMailAggregator restart

Hello @fradarr
Sorry for the late reply.
You have deployed a new server. If so, please provide us with fresh logs (Community server\Mail server).

As for other issues (Control Panel, Document server). Do the issues still persist at the moment? If so, please provide us with details and show us output result of docker ps command (on the host).

One more thing. Is it possible to provide us with test account to your portal? This way we will check out issues on the spot. If so, please contact me via PM.

1 Like

Hello @Alexandre
Thanks for your support. We started using the portal and in order to use documents I modified the ‘local.json’ file inside the document-server container to “token ->false” since I couldn’t figure out the right way of implementing the security token. Hier the fresh logs and yes I will DM you with access data.

Thanks !

Logs:
http://46.231.204.15:8080/d/1607fe4e2ab942eda975/

I still quite offen get :

And the load explodes from time to time (close to 300% CPU usage on docker stats for mail and community server).

But thank God and all the IT giants, docker handles the revival and it’s usable for our small team.

Hello @fradarr
I’ve sent you a message in DM.

Thanks for the outstanding support, all my issues have found a solution so thanks again, great software and great team here, cheers!

2 Likes