ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

Mail module: issue with support Office365 accounts assigned to the AD/AAD

There is a problem to attach a Office365 account in the Mail module.
It works correctly for accounts NOT assigned to the Active Directory or Azure Active Directory,
but if account is assinged to AD/AAD tenant, there is a unknown issue occurding during attaching account.

According our investigation the problem is realted to missing support for OAuth2 for Outlook365. Have you had this kind of issue.

Is it somehow related to ONLYOFFICE Api Documentation - Create the OAuth account ??

Community Server/Control Panel version: source code from 12.2020
Type of installation of Workspace (docker, deb/rpm, exe): Azure VM, local IIS
OS: Win10 Server
Browser version: Chrome/all

Hello grzegorz.palmer.

Sorry for the late reply.

Could you please reproduce the issue and send us whole Community server logs folder. It’s located here: Program Files (x86)\Ascensio System SIA\CommunityServer\Logs

We need to check it out.

Also please run a test. Change password for test account and try to reproduce the issue.

Hi Alexandre

I’ve made 2 tests: with correct and incorrect password. In the attachemnt you can find a screenshot of logs.

What is important, in this same time I’ve tried to login via outlook.com and it works correctly.

Btw, I’ve made this same test today morning (12.11.2021, around GMT 6:37) on cloud version (Authorization - ONLYOFFICE) and issue is that same.

Best Regards
Gregory

Hello Gregory.

Could you please run a test? Please try to reproduce the issue with Thunderbird (use your test account). Will there be the same result as Outlook?

As for the issue in general, please double check your AD and DNS settings (for example, AD Conditional Access policy). It seems to me that the issue is related to some setting that does not allow the use of third-party apps.