ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

Loading Failed for Document Service and Control Panel

Type of installation of Workspace (docker, deb/rpm, exe): exe
OS: Windows server 2016
Browser version: Firefox 108.0.2

I am trying to set up OnlyOffice workspace on local standalone machine… It is not connected to any network. How should i set up Document Service Location Page ( in Administrator settings) ? It says ‘Document Service is not available’ on clicking any document. And also Control Panel opens up a blank page which says ‘cannot GET http://localhost/controlpanel.backup/’ on inspecting.

My installation was correct with no issues. Thanks in advance

Hello @OnlyOfficeTester
Please point me to the guide which you used for Workspace installation.

I am trying to set up OnlyOffice workspace on local standalone machine… It is not connected to any network.

Did you open the portal via http://localhost in your tests? Is the server available in your local network?

Also please:

  1. Go to your portal > Settings > Integration > Document service > click Save button and make a screenshot of entire page.
  2. Open Control Panel with opened browser console (F12 in Google Chrome), check Console and Network tabs, please make screenshots of any error entries (entire page).

I used this link for installation, followed it exactly: Installing ONLYOFFICE Workspace for Windows on a local server - ONLYOFFICE

Yes, I used localhost for testing. This is a private network.

Document Service Path doesn’t seem to work. It was working earlier until I touched it. Sometimes it shows “Api url: service is not defined” in the error message.

Thanks for the quick reply.
(Sorry for replying so many times, I am allowed only to attach one image per reply)

When opening any document it shows either a blank page or this:

Is Document server welcome page available on http://localhost/ds-vpath/ ?
As far as I see, you have opened the portal via some DNS name (win-45***). Is portal available via localhost (go to the server itself > open a browser > go to http://localhost).

The page http://localhost/ds-vpath/ is not available but http://localhost/ is working correctly

Does the issue reproduce via localhost (not via your domain name win-45***) too? I mean please go to the portal via localhost > DS integration page > click Save button.
Also please go to Windows services and check that all Document server services run.
A few more things. Please clarify if there’re any firewall or proxyserver in front of Workspace.
Also please provide us with Document server logs folder. it’s located here: Program Files (x86)\Ascensio System SIA\DocumentServer\Log