License migration


I’ve got a lifetime license for onlyoffice with updates up until version 7.5 running currently inside a docker container. I need to migrate the OnlyOffice instance to a standalone VM and decomission the docker one.

The problem is, that when I build a VM, install OnlyOffice 7.5.0 build 125 and apply the license I don’t get any errors regarding lic expiration, but when I open the mobile app I cannot edit anything.

Is there a procedure regarding licence migration or maybe I’m missing something?

Document Server version: 7.5.0 build 125
Type of installation of the Document Server (docker, deb/rpm, exe) : docker to .deb
OS: Debian 12

Hi @lcs,
If you cannot open mobile editors, it means you are probably using the Community Edition Document Server.
You can check it with apt list --installed | grep onlyoffice
CE package is named onlyoffice-documentserver
In order to use mobile editors, you need onlyoffice-documentserver-ee or onlyoffice-documentserver-de depending on your license.

Hi @Carl,

You were right. That is part of the problem. I’ve purged onlyoffice-documentserver and installed onlyoffice-documentserver-ee=7.5.0-125. Now on the wellcome screen I can see " ONLYOFFICE Docs Enterprise Edition installed", but edit via mobile app is still no go.
Via web everything is working fine, integration with nextcloud is working fine. No error messages whatsoever.

You need to clear the cache of the mobile app to avoid the issue.

That worked.
Thank you, Carl !