Issue with Reading Dates in Brazilian Format in CSV Files

Hello,

I hope you are well. I would like to report a problem that I identified in the latest version of ONLYOFFICE Desktop Editors (version 7.5.1.23 - rpm) while using it on Fedora Linux 39 (Workstation Edition).

The issue arises when I try to open CSV files containing dates in the Brazilian format (DD/MM/YYYY) in a spreadsheet. It seems that ONLYOFFICE cannot interpret these dates correctly, leading to errors in reading and displaying the information.

Here are some examples of dates in the Brazilian format that are causing issues:

test.csv

Date example 1;15/11/2023
Date example 2;22/07/2022
Date example 3;03/04/2021

When attempting to open the CSV file containing these dates, I notice that the spreadsheet does not recognize them correctly. I have tried using different encodings, such as Unicode (UTF-8) 65001 and Western European (Windows) 1252, but the problem persists.

I have included an image to illustrate how the dates are displayed in the spreadsheet.

Olá @jlsmartins :handshake:
Thank you for the detailed description!

We are checking the situation.
I will let you know when I get something.

@jlsmartins

At the moment, there are issues with date formats when opening CSV files. Our team is already aware of this problem.

As a temporary solution, you can use the following steps to retrieve data from a CSV file:

  1. Go to the Data tab → Get dataFrom local TXT/CSV
    // Go to the Dados tab → Obter dados → De TXT/CSV local

  2. Choose the necessary file and load the data into the table.

Hello @Nikolas,

Just wanted to drop a quick note to say thanks for the speedy response and the solution you shared. I tried out the steps you mentioned, and it worked like a charm for getting data from the CSV file with those Brazilian date formats.

Really appreciate your help! It’s awesome to see such quick and useful support from the ONLYOFFICE team.

Thanks again!

1 Like

Has there been any progress on this problem?

image

@TxTechnician
Does the issue persist both when importing and opening a .csv file?


Unfortunately, there’s no information yet about the editor version incorporating fixes for this bug.

I’ve been testing version 8.0.0 installed from Flathub, and the issue persists. Just to clarify, the problem occurs only when I try to open the file directly. However, if I open OnlyOffice first and then use the ‘Get data’ option, the file is imported correctly.

2 Likes

Same here, 8.0.0 from Flathub. I’ll just have to open csv files with “get data” until this is fixed. I checked the release notes for 8.0.1 and didn’t see anything about a fix for this. Is there a github issue we can track maybe?

@lewisacres @jlsmartins
At the moment, this bug is not fixed. We will do our best to include this correction in version 8.1.0.

Unfortunately, I can’t promise.