iOS: dictation not working correctly in mobile app


ONLYOFFICE Mobile: Documents
Do you want to: Report a bug
Device: iPhone12
Device language: German
Keyboard: iOS standard keyboard, German, dictation enabled
OS version: 16.5
App version: 7.3.1
Mode: both, connect to Cloud / On Device

Steps to reproduce the bug:

  • open mobile app
  • tap 2nd tab (ONLYOFFICE), the app shows the folder “my documents” of a logged in DocSpace
  • tap + symbol on top and press Document to create a new document
  • document opens, cursor is blinking
  • tap microphone symbol on iOS software keyboard (bottom right corner of keyboard) to dictate
  • dictate something, in my example “Hallo, dies ist ein Test”, cursor starts blinking faster but no text appears at all
  • press microphone symbol again to end dictation
  • only the letter “h” appears from the dictation - it seems to be the first letter of the dictation but the text dictated never appears

Description of the bug

There are two bugs:

  1. The live dictation does not appear while speaking and dictating, i.e. no words appear during dictation. This is different behaviour from standard iOS dictation e.g. in Pages
  2. More severe, the dictation does not work, only output is the first letter of the first word dictated.

I tried to reproduce the error with a new on device document and also with a new iCloud document and on both, strangely enough, only the 1st bug appears, in that only the live dictation does not work - the dictated text in these two modes appears after you end dictation by pressing microphone button.

Can you please try to reproduce the bugs and let me know?
Best regards, Mario

Hello @Mario

I was able to reproduce this issue. We are analyzing it, once any news come up I will update this thread.

Unfortunately, I wasn’t able to reproduce this issue. I’ve tried several languages (English, Spanish, German) and it always inserts dictated text accordingly. I’ve tested it on device, connected to DocSpace portal and connected to the Nextcloud portal.
Are there any additional steps to reproduce this issue?

We have registered the behavior with ‘live dictation’ from the 1st mentioned by you bug in our internal track system. Thank you for reporting that.

As for the 2nd bug, If you have any additional information in this regard, please let me know.

Thanks for registering the 1st bug.

I tried it on my iPad Pro and I had the exact same behaviour as reported in my initial post of this thread. So, maybe the 2nd bug has to do with my very DocSpace?
If you PM me your email address or your alias email address I could create a test room in my DocSpace, test myself, then invite you to the test room for testing purposes. Pls let me know. (Note that the email address used for my DocSpace is different than the one used for this forum account.)

Please try reproducing the issue with your DocSpace in the first place. If you are able to reproduce it, please let me know.