ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

iOS App Documents "Connection lost" error

Hi guys,

I have a problem with the iOS Documents App and I would like to ask, if someone can help me. When I try to open any type of document from my cloud server I get the error “Connection lost. You can view this file, but not edit it” (error message translated by me).

My setup is the following:

  • Virtual private server at contabo running Ubuntu 20.04
  • OnlyOffice Workspace (MySQL, document server, control panel and community server; the mail server is NOT installed) running as docker container. For the setup I followed this. guide
  • For HTTPS access to the portal I used this guide.
  • I also have Nginx Proxy Manager running to get Let’s Encrypt certificates and to connect to the Portal via HTTPS
  • A UFW firewall is also installed on the vps.

In the Web Browser the Portal is accessible and I can also view and edit any type of document. For the iOS Apps Portal and Documents, I can login to my account and in Portal I have regular access to everything. But when I try to open any kind of document, I get the error message from above. Log out and back in didn’t help.

Has anyone an idea, where the problem could be?

Thank you very much for your help!

Maginos

Device: iPhone 13
OS version: 15.1.1
App version: 6.6
Mode: Connect to Cloud
Browser version (for Web editors): Brave, Safari

Hello Maginos.

Is it possible to provide us with test account to your portal? So we are able to reproduce the issue.

If so, please send me account credentials via PM.

As for the issue in general. Please reproduce it and make a screenshot of an error. Also attach whole Community server logs folder to your reply. It’s located here: /app/onlyoffice/CommunityServer/logs/

For HTTPS access to the portal I used this guide.

By the way, docker installation allows you to obtain Let’s Encrypt certificate or use your own one in the most simplest way (using portal Control Panel > HTTPS). As far as I understand your network scheme, you ran CS container with -p 443:443, but you used proxy server in front of portal for https requests. Is it correct?

I just sent you a PM with the required information.

I have port mappings -p 445:443 and -p 85:80 for CS and -p 80:80 and -p 443:443 for Nginx Proxy Manager.

So with the help of Alexandre I got it working. Following steps were required:

On Web Portal:

  • Under Settings, Document Service, paste the URL from the web portal in “Community Server address for requests from the Document Service”

  • Under Settings, Customization, DNS Settings, enable “Custom DNS Settings” and paste the URL to the web portal again

Since I have running Nginx Proxy Manager running in front of my OO installation, I had to change some settings there as well. Following settings refer to Community Server AND Document server:
Section “Details”:

  • Cache Assets → enabled
  • Block Common Exploits → disabled
  • Websockets Support → enabled

Section “SSL”:

  • Force SSL → enabled
  • HTTP/2 Support → enabled
  • HSTS Enabled → enabled
  • HSTS Subdomains -->disabled

Maybe not all changes on NPM are required, but with these settings it works.

1 Like