ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Intregration Onlyoffice with Nextcloud

HI Team,

I m trying to integrate Onlyoffice with nextcloud. BUt i m facing Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.) (version 7.0.0.132) error while connecting onlyoffice from nextcloud.

Nextcloud and office installed on oracle7 Linux.

I used this one:-
'allow_local_remote_servers’ => true, ‘onlyoffice’=> array ( ‘verify_peer_off’ => true, ),
changed value of “rejectUnauthorized”: from true to false in /etc/onlyoffice/documentserver/default.json

But still not working any solutions for me.

Please look into this as well .
https://help.nextcloud.com/t/intregration-onlyoffice-with-nextcloud/135031

https://github.com/ONLYOFFICE/onlyoffice-nextcloud/issues/597

Please help me, looking your a quick reply. We want to put it in productions.
Thanks

Hello @sushant
Let’s focus on one communication channel. Please do not post additional posts on GitHub. Let’s try to fix it here.

I read all information on both links and I have a few questions:

  1. Nextcloud version and connector app version.
  2. As far as I understand, the integrated example works properly and the issue is related to integration only. Please reproduce the issue (click Save button in the connector app) > provide us with fresh Document server and Nextcloud logs.
  3. I see that users on Nextcloud forum offered you to run wget command from Nextcloud server to Document server and vice versa. But I can’t find a screenshot with output result when you are running wget from Document server to Nextcloud.

Hi @Alexandre

I m currently using 23.0.2 Nextclou in docker container. and I m not sure about connector app version can you help me to find out it.
Here is out put i m running wget command from office server to nextcloud server

[root@OOFFICE ~]# wget https://nx.exadime.com/
--2022-03-16 09:47:46--  https://nx.exadime.com/
Resolving nx.exadime.com (nx.exadime.com)... 10.0.0.40
Connecting to nx.exadime.com (nx.exadime.com)|10.0.0.40|:443... connected.
ERROR: cannot verify nx.exadime.com's certificate, issued by ‘/C=GB/ST=Greater Manchester/L=Salford/O=Sectigo Limited/CN=Sectigo RSA Domain Validation Secure Server CA’:
  Unable to locally verify the issuer's authority.
To connect to nx.exadime.com insecurely, use `--no-check-certificate'.
[root@OOFFICE ~]#

The connector app version is in your applications directory in Nextcloud. Just in right of OnlyOffice you’ve got the version

Hi @Irwin/@Alexandre

Thanks @Irwin for the help, please see the connector app version, in attached file.

Hi @sushant

Judging by the screenshot you posted on Github, you’ve entered the same address for the Document Server and Nextcloud in the Advanced server settings in Nextcloud. That assumes that Nextcloud and Docs can reach each other via the same address, which is, of course, not the case.

You should try to either leave both of the Advanced server settings fields empty or enter the Document Server address (office.exadime.com, I assume) in the first one and the Nextcloud address (nx.exadime.com) in the second one.

Hi @Serge

Thanks for the reply.
Are you suggesting like this please see attached pic, if I m wrong then correct me please .

Hello @sushant
No, nx.exadime.com is your Nextcloud portal address. But you set it in the first field (DS field).
Please set Document server address in the first field as @Serge mentioned and click Save button. Please let us know the result.
As for other fields, please try to leave them empty.

Hi @Alexandre ,

Thanks for the reply, I tried as you suggested please see the below pic for reference.

Thanks,
Sushant

I sent you a message in PM, please check it out.