Internal WebDAV for OnlyOffice WORKSPACE

Do you want to: Report a bug
For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem:
When I try to connect to WebDAV OnlyOffice WORKSPACE Communite Edition at http://ip_portal_address/webdav with credentials from the portal user using Windows, I get the following error:
“Error code: 0x800770043
Network name not found.”

When I try to connect through a Web browser, I get an HTTP ERROR 405 error - This page is not working right now.

The functionality of the built-in WebDAV is described in the documentation (everything is done according to the documentation) - Configuring ONLYOFFICE WebDAV server - ONLYOFFICE

All accounts tried for authorization from the portal are completely valid (it’s not a matter of matching the login-password pair).

How to fix this problem?

Community Server/Control Panel version:

  1. Control panel version:
  2. Community Server version:
  3. Document server version:

Type of installation of Workspace (docker, deb/rpm, exe): docker
OS: Ubuntu 22.04.3 LTS

hi @d.raev

As suggested on GitHub, you can add BasicAuthLevel --> (2) .

For Windows File Explorer, you can try the following solution:

  1. Open the registry editor (regedit). image_2023-11-30_17-47-22

  2. Navigate to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services > WebClient > Parameters.

  3. Find the entry BasicAuthLevel and change its value to 2.

  4. Reboot your PC.

Please let us know if this resolves your issue.

Could you please clarify whether the issue was resolved after making changes in the Registry Editor?

Thanks a lot! This helped, but now a new problem has appeared. The directory is empty and nothing can be done in it - there are not enough rights.
The DavWWWRoot directory is loaded.

Something seems to be off here. Can you provide the steps you followed to connect? (Step by step)

  1. I made changes to the registry as described above.
  2. I rebooted.
  3. I went into Explorer, right-clicked on “This PC” and clicked “Map network drive…”
  4. In the folder field, indicated the address to the internal WebDAV server from OnlyOffice -
  5. I left the “Restore connection when logging in” checkbox checked, and also indicated “Use other credentials.”
  6. In the window that appears, enter the credentials to access the portal. By default, it does not accept the email (aka login)-password pair, but it accepts the login-password pair synchronized via LDAP. We log in as the owner/administrator of the portal.
  7. The network drive is connected, but it is empty and we see the “DavWWWRoot” directory (we do not see any portal structure).

Now I have enabled SSL (HTTPS) and now I cannot access WebDAV over HTTP or HTTPS. Now it gives a new error:

Network drive mapping failed due to the following error:

The network has not been logged in.
Снимок экрана 2023-12-06 182513

The web.webdav.log has the following error:

2023-12-05 07:56:29 - error: requestAPI.getStructDirectory | Request failed with status code 500 | GET /api/2.0/files/@root | undefined | Недостаточно прав для просмотра папки

It seems that the issue is related to connecting LDAP user.

I’ll leave a link to GitHub since it appears that you have encountered or reproduced a bug.
My colleague will assist you further.

someone else told you to change the basicauthlevel to “2”, this is incorrect it should be “1”.

BasicAuthLevel = 1

This error you are getting can be caused by the local windows machine you are connecting from not having the “WebClient” service running. Normally it starts automatically when you try to map a drive to webdav, but in some cases it does not.

Here is what solved it for me:

Ref. How to fix error: 0x80070035 Network path was not found when mapping a network drive to WebDAV (

If it’s already running, try restarting the service.

1 Like