Internal server error after installation of redmine plugin

I am trying to test OnlyOffice integration with Redmine. I run both of them in docker containers. Installtion went fine, I deployed a community edition and tried to edit a few documents, so far so good.

Installing a plugin went fine as well. Then I went to configure it and entered a ‘http://localhost:8081’ (tried 8082 as well) as an address of the document server because I mapped ports from OnlyOffice container like this:

      - '8081:80'
      - '8082:8080'
      - '4433:443'

I did this simply because 80 is occupied by Redmine web interface. I also specified a JWT in my docker configuration and entered it as well. I did not enter anything in the advanced server settings section because I do not quite understand their meaning and I could not find any good explanation of those in the docs.

So, when I did all of that I tried to save the settings and got an ‘Internal error’ at the page top.

Couldn’t find anything in Redmine logs as well as in OnlyOffice logs (as far as I know about them, at least nginx error logs)

Can anyone explain what I might be doing wrong?

Document Server version: v8.0.1.6 as I can judge from ‘git log’
Installation method: docker containers
OS: Linux kernel 6.6.16
Browser version: FF 122.0.1

Please avoid creating duplicate threads for the same issue. There’s no need for that.
I will close this thread and provide a link to your initial inquiry.