Install Workspace on Debian with packages with external DB and Mailserver


I want to install Workspace on a fresh Debian System. I saw I could use options like mysql-host etc. But it does not seem to use my external Server then. Although I could not find any information about how to setup the System without installing mysql / postgre / Mailserver. These are all System I have up and running and it would be an administration overhead to have two of each. Could anybody explain how to use these Systems as external deamons?

Thank you


Unfortunately, additional script parameters, such as external MySQL host, are available only for Docker installation. There is no possibility to avoid installing all the dependencies to the server when running a deb-package installation.

Hi Carl,

thank you for your fast reply.
Ok, I understand that. “Install” ist not the big Problem, as I can export the databases to my Server and disable it on the oo-host.
Is it possible to give all oo-packages another db-host / user / pass with config? Would that be stable when installing updates in future?
Do I have to install oo-Mail (-server) to have the Webmail working with my Postfix Mailserver?

Thank you


Hi Marius,
There are multiple configs where you need to set up database connection, and it has to be done manually. Moreover, all configs will be overwritten during updates so I would not recommend changing them. The easiest way for a package installation is to just have a local database instance that is installed by the script.

As for mail, if you already have a mail server of your own, you don’t need to install our mail server. Just connect your mailboxes to the Mail module of the portal.

Hi Carl,

thank you for these informations.
This is not really cool, and - of course - I don’t like to have another Database-Server to be maintained and backuped.
But I tried to install the complete package. That doesn’t work because the debian mysql version is not supported by the install tool.
So I tried on a newly installed absolutely clean machine to install the docker version to play with.

bash -md -ims false -it WORKSPACE -ms false -mysqlrp xxxxxxxx -mysqlp xxxxxxxxxx

That installes but does not start the server. Mostly I get an “Not reachable” / “ERR_INVALID_RESPONSE” from Chrome, but sometimes onlyoffice generates “502 App Crash”.

What I did after debian install was to enable networking and ssh. Nothing else. I installed with your script, the docer version.


Perhaps there is a problem with “secure passwords” and your install-script??!!
But first I tried to connect to mysql within the container with both user. That works well.
So mysql is setup with correct passwords. Don’t know if the deamons are able to use these?!
30 characters with letters, numbers and special characters

2022-05-09 14:14:12,476 ERROR [5] ASC.Web - Warmup error System.Collections.Generic.KeyNotFoundException: The given key '3889' was not present in the dictionary.
  at System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) [0x0001e] in <f2b3ab7dfff746f594d2ef5b16ec3c90>:0
  at MySql.Data.MySqlClient.MySqlField.SetFieldEncoding () [0x00034] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.MySqlField.set_CharacterSetIndex (System.Int32 value) [0x00007] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.NativeDriver.GetColumnData (MySql.Data.MySqlClient.MySqlField field) [0x000ad] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.NativeDriver.GetColumnsData (MySql.Data.MySqlClient.MySqlField[] columns) [0x00004] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.Driver.GetColumns (System.Int32 count) [0x0001c] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.ResultSet.LoadColumns (System.Int32 numCols) [0x00000] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.ResultSet..ctor (MySql.Data.MySqlClient.Driver d, System.Int32 statementId, System.Int32 numCols) [0x0002a] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.Driver.NextResult (System.Int32 statementId, System.Boolean force) [0x00039] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.MySqlDataReader.NextResult () [0x000d5] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.MySqlDataReader.Close () [0x00039] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.MySqlDataReader.Dispose (System.Boolean disposing) [0x00003] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.MySqlDataReader.Dispose () [0x00000] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.MySqlCommand.ExecuteNonQuery () [0x0004b] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.Driver.Configure (MySql.Data.MySqlClient.MySqlConnection connection) [0x0017e] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at MySql.Data.MySqlClient.MySqlConnection.Open () [0x0023e] in <8235ed0ad41343b3a11f3dc973b415b6>:0
  at ASC.Common.Data.AdoProxy.DbConnectionProxy.Open () [0x00012] in <96a81f2b5ce744ef90c32874e89bb46b>:0
  at ASC.Common.Data.DbManager.OpenConnection () [0x00006] in <96a81f2b5ce744ef90c32874e89bb46b>:0
  at ASC.Common.Data.DbManager.get_Command () [0x0000e] in <96a81f2b5ce744ef90c32874e89bb46b>:0
  at ASC.Common.Data.DbManager.ExecuteList (ASC.Common.Data.Sql.ISqlInstruction sql) [0x00000] in <96a81f2b5ce744ef90c32874e89bb46b>:0
  at ASC.Common.Data.DbManagerProxy.ExecuteList (ASC.Common.Data.Sql.ISqlInstruction sql) [0x00006] in <96a81f2b5ce744ef90c32874e89bb46b>:0
  at ASC.Core.Data.DbBaseService+<>c__DisplayClass8_0.<ExecList>b__0 (ASC.Common.Data.IDbManager db) [0x00000] in <29abe7af31c84de4b7a176f4d96b10be>:0
  at ASC.Core.Data.DbBaseService.Execute[T] (System.Func`2[T,TResult] action) [0x00007] in <29abe7af31c84de4b7a176f4d96b10be>:0
  at ASC.Core.Data.DbBaseService.ExecList (ASC.Common.Data.Sql.ISqlInstruction sql) [0x0000d] in <29abe7af31c84de4b7a176f4d96b10be>:0
  at ASC.Core.Data.DbTenantService.GetTenants (ASC.Common.Data.Sql.Expressions.Exp where) [0x00007] in <29abe7af31c84de4b7a176f4d96b10be>:0
  at ASC.Core.Data.DbTenantService.GetTenants (System.DateTime from, System.Boolean active) [0x00048] in <29abe7af31c84de4b7a176f4d96b10be>:0
  at ASC.Core.Caching.CachedTenantService.GetTenants (System.DateTime from, System.Boolean active) [0x00000] in <29abe7af31c84de4b7a176f4d96b10be>:0
  at ASC.Core.TenantManager.GetTenants (System.Boolean active) [0x00000] in <29abe7af31c84de4b7a176f4d96b10be>:0
  at ASC.Web.Studio.Core.WarmUp..ctor () [0x0006b] in <92e42f68b5a7453f81f4ac8c66bb234d>:0

Going down to:

bash -ims false -it WORKSPACE -ms false

results in:

Please do not reload the page or shut down your computer.
We are working on it.

I waited for an hour now. Nothing changes. Every install was on a fresh installed system nothing there from previews installations.

Ok, bash and Docker → y, mailserver-> n results in the same “502 App Crash”

Communityserver is restarting every 60 seconds:

Hi, please specify the version of Debian installed on the server. Also send me the output of
docker logs onlyoffice-community-server

Just did a fresh install.
It is a complete fresh Debian 11.3.0 with only Network setup und ssh enabled. Nothing else changed.

Installation with:
bash ./ -ims false -it WORKSPACE -ms false
Install with Docker [Y/N/C]? Y

I sent Logs with pm.
I did ca. 20 Docker installs for now. Now one was startable. Some did automatic restarts as described before. The one I did now, does not restart automatically but seems like elastic search is not starting.

We’ve had similar issues on previous versions of Debian 11 (CS container not starting), but they were fixed.

We will check if the issue is reproduced on our side with Debian 11.3.

If it helps, I can give you access to the Server.

We have managed to reproduce the issue with the current installation. However, with Community Server v12.0 the issue is not reproduced, so I’d recommend waiting for the release of the update. It will happen in the next couple days.