Install DocSpace Community on Windows Server 2019 Essentials


I’m trying to install DocSpace Community on Windows Server 2019 Essentials. At the end of the installation, I get the following message:

There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

At the same time, I see that the Docs services have been installed and are working:

The versions of some programs I have do not match the requirements:
Is required / Installed
MySQL Connector/ODBC 8.0 x86 / MySQL Connector/ODBC 8.0.33 x86
MySQL Installer Community 8.0 x86 / MySQL Community Server 5.7
Node.js v.18.16 / Node.js v. 20.11.1
Elasticsearch v.7.10 x64 or higher / Elasticsearch v.8.12.2
Erlang v.26.0 x64 / Erlang v. 26.0.2
RabbitMQ v.3.12 x64 / RabbitMQ v.3.12.13
Redis 5.0 x64 / Redis 5.0.1
PostgreSQL v14.0 x64 / PostgreSQL v16.2

Please tell me which of these components are critical and may prevent the installation of DocSpace?


Is there any solution?

I tried to install DocSpace on a clean “Windows Server 2019 Standard” system - the result is the same.
Has anyone else tried installing DocSpace on Windows Server?

Hello @ivaf

Please provide DocSpace Installation log which should be located here:


By the way, do you use non-latin symbols in <username>?

Yes, I’m sorry. My mistake. Some of the programs were installed from under an account that has non-Latin characters in its name.
I’m closing the question.

1 Like

I am glad to hear the issue is resolved now. I am closing this thread.