Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

I can't write symbols like \ @ # € (Mac version)

Hi, this is probably a newbie problem, but I use OnlyOffice Desktop for Mac and I can’t type any symbol that uses the option+key combination, like for example:
@: option+2
€: option+e
I only have this problem with OnlyOffice. In all other applications it works for me. Is there any way to fix it?
Thank you very much.

1 Like

Hello @toni
Please let us know your Desktop Editors and MacOS versions. Are you trying to use mentioned special characters in docx file?

Hi, I’m using OnlyOffice 7.1 (532) x85_64 and MacOS 10.14.6 and MacOS 12.4.
The problem occurs in .docx, but also in other document types, spreadsheets and presentations.I have tried different types of keyboard (Mac and Logitech), different language keyboard settings (Spanish, Spanish ISO, English…) and the problem remains.

thank you, we need some time to check it out. I will update this post when we have something to share.

We have checked the situation and we are able to reproduce the issue with @ (option+2). We added a bug to internal tracksystem (internal number - 58111).
But we can’t reproduce the issue with:
€: option+e

Could you please re-check the issue? Do you use this hotkey correctly?

Hi, I’m now able to use the € symbol, but not the @, #, |… ones.
Thanks!

Hello @toni

I’m now able to use the € symbol

What was changed after your previous test?
As for # and | symbols, please provide us with detailed scenario (did you try to run these hotkeys in docx file? also please clarify the exact hotkeys which you hit).

Hi, about the € symbol, I can now use it in documents with version 7.1.1, but I still cannot use it in presentations or spreadsheets.
I still cannot use the following symbols in documents, presentations or spreadsheets: \ | @ # [ ] { }.
All the symbols I can’t type are with the option + another key combination.

Hotkeys in a spanish keyboard:

option+º: \ (backslah)
option+1: |
option+2: @
option+3: #
option+`: [
option++: ]
option+´: {
option+ç: }

about the € symbol, I can now use it in documents with version 7.1.1, but I still cannot use it in presentations or spreadsheets.

We know about this situation (internal bug number - 57410), we are working on it.

option+2: @ - this hotkey issue is related to bug 58111. As for other mentioned hotkeys, we are checking the situation. I will update this post when we have something to share.

Hotkeys in a spanish keyboard:

option+º: \ (backslah)
option+1: |
option+2: @
option+3: #
option+`: [
option++: ]
option+´: {
option+ç: }

We have added mentioned situations to bug 58111. We have started working on it.
Thank you for pointing us to this situation!

Hello Alexandre,

same problem here.
I am on version 7.2 with Macos 10.15 and
All “alt+num” symbol shortcuts are not working;

They suppose to be like below but not working;

alt+": <
alt+1: >
alt+2: £
alt+3: #
alt+4: $
alt+5: ½
alt+6: §
alt+7: {
alt+8: [
alt+9: ]
alt+0: }
alt+*: **
alt±: |

Hope this will fixed soon.
Thanks.

Hello @volkanada
Thank you for your description, we are checking the situation.

Hello @volkanada
We have added your request to internal tracksystem (59171). We are working on it already.

Thanks! Waiting to hear from you.