Hyperlink to local files (not allowed)

OS version: Windows 11 Pro
App version: ONLYOFFICE Desktop Editors
Downloaded from: ONLYOFFICE website

I have a simple Spreadsheet with one hyperlink to an image on my local filesystem.
Path to the image is: C:\output\picture.jpg
So I set the hyperlink to: file:///C:/output/picture.jpg

When I click on the hyperlink, I get the following error:
Not allowed to load local resource: file:///C:/output/picture.jpg (in Console @ debug mode).


How can I give DesktopEditors access to local filesystem?

Hello @joeyoo

Could you please specify what exactly happens after you click on the link? A small video demonstration would be perfect.
Also, please run a test and insert the link into the browser to check if it can access it.

Hello @Constantine,

browser throws the same error.

Below is a link to a simple video demonstration of my problem:
Simple video demonstration

That’s weird, but I’m afraid that if browser cannot open it too then the issue is not related to our editors.
Check the folder properties, more specifically Security tab and access permissions there.

I think it’s normal that browser can’t open local files due to security reasons (can’t execute random files on computer). But DesktopEditors should be able to open this.

I checked the security settings on “output” folder and “picture.jpg” and I added “Everyone” to both, with full permissions. Still same result.

I tried to re-create the same thing in Microsoft Excel and Excel opened the file without a problem, so file is definitely accessible.

That’s a fair point. I’m checking the situation.
I will update this thread once I get any news.

Hello @joeyoo

We have tried to preproduce the issue on Windows 11 Pro and Windows 11 Home but it wasn’t successful. Possibly the issue is related to the picture itself. Is it possible to send us the picture that you have problems with please?
Also, please do another test and try to reproduce the issue with any other file and also record a video.

Hello @Constantine,

I have recorded a new video, creating a new text file and creating hyperlink to it on DesktopEditors and Excel, so you can see the difference.
Security permission to the file is “Everyone” with “Full control”.

Comparison link

I tried this same thing on 3 different computers (2x Windows 10 Pro, 1x Windows 11 Pro) and it’s the same problem everywhere.

Hello again @joeyoo

Please run another test and use link as file:///C:\output\picture.jpg with backslashes and check if makes any difference.

Hello @Constantine,

I tried that and some other variants too and there is still “Not allowed” error.