Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

HTTPS not generated on domain

I have recently installed WS Communty Edition on Ubuntu server and almost everything works smoothly, but I am having problems to generate and to apply the SSL certificate through the control panel.

It does enable the HTTPS connection, but the certificate is indicated to “-”, therefore the website is considered as risky by the browser.

It did work before to this same system, to another subdomain, but since I changed the subdomain it never worked.

Thanks,
Bruno

Hello @brunoleonadvogado

Currently, we do not have certificate generation for multiple portals via Control Panel.
To achieve this we added script as a workaround to the the Community Server. Find the script in var/www/onlyoffice/Tools/letsencrypt.sh.
While executing the script you have to point out both of your portal domains, so the command without need to enter the container will look like this:
docker exec -it onlyoffice-community-server bash /var/www/onlyoffice/Tools/letsencrypt.sh portal1.domain.name portal2.domain.name
where portal1.domain.name and portal2.domain.name are the domain names of your portals.

It simply worked Constantine, your product is simply amazing guys!

Tks,
Bruno