ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

How to reset admin password via Linux command line?

I have been asked to help someone recover access to a dedicated OnlyOffice server.
I have root access to the machine running Linux.
From what I understand there was only one admin user for the web interface and they lost their password.
It does not look like the outgoing SMTP is configured or working.
I need some way to reset their admin password, or create a new admin user so we can regain access and restore service.
I tried setting up the logging to track outgoing email and find a password reset link, but that has not worked.

Is there a solution?

Hello @SS-Support
I believe we have to start with SMTP troubleshooting.
Please go to the host and run service onlyofficeNotify status (for docker, run it inside Community server container) > check the status, if it’s necessary, restart this service and ask your user to try to restore password again.
If it doesn’t help, please provide us with whole Community server logs folder. It’s located here:
docker : /app/onlyoffice/CommunityServer/logs/
deb\rpm: /var/log/onlyoffice/

By the way, please point me to the guide which you used for Workspace installation. Also let us know component versions (versions of Community server, Control Panel, etc.)

Hello Alexandre,

Here’s the output:

# service onlyofficeNotify status
Redirecting to /bin/systemctl status onlyofficeNotify.service
● onlyofficeNotify.service - onlyoffice Notify Service
   Loaded: loaded (/usr/lib/systemd/system/onlyofficeNotify.service; enabled; vendor >
   Active: active (running) since Tue 2023-02-21 12:06:31 PST; 2 days ago
  Process: 1813 ExecStart=/usr/bin/mono-service -d:/var/www/onlyoffice/Services/TeamL>
  Process: 1777 ExecStartPre=/bin/bash -c rm -f /tmp/onlyofficeNotify (code=exited, s>
 Main PID: 1820 (mono)
    Tasks: 49 (limit: 101963)
   Memory: 132.2M
   CGroup: /system.slice/onlyofficeNotify.service
           └─1820 /usr/bin/mono /usr/lib/mono/4.5/mono-service.exe -d:/var/www/onlyof>

Feb 21 12:06:30 systemd[1]: Starting onlyoffice Notify Ser>
Feb 21 12:06:31 systemd[1]: Started onlyoffice Notify Serv>
Feb 21 12:06:54 mono[1820]: /var/www/onlyoffice/Services/T>

Additional information:
Firewall ports 25/587 are open. Attempt to send mail resulted in this log entry:

svcNotify.log:2023-02-24 10:33:40,854 ERROR [4150] ASC.Notify - Tenant: 1, To: - System.Net.Sockets.SocketException (0x80004005): Connection refused

These are the general install instructions used:

mkdir /downloads
cd /downloads/
wget ...
bash /var/www/onlyoffice/Tools/
vim /var/www/onlyoffice/WebStudio/web.appsettings.config
service monoserve restart

(Note: is not a real domain. I have cut out the real domain for privacy)

Is it possible to disable firewall for a test? Do I understand it right that you installed package version of Workspace (without docker container of Mail server)? Please go to the host and run apt list --installed | grep onlyoffice, please show us the result.

Hello Alexandre,

I tried disabling the firewall but the message still does not go out. Same error:

svcNotify.log:2023-02-28 11:14:29,642 ERROR [9779] ASC.Notify - Tenant: 1, To: - System.Net.Sockets.SocketException (0x80004005): Connection refused
[root@office ~]# rpm -qa | grep -i onlyoffice

The server is running Oracle Linux 8.3.


These are really old versions. I believe it’s better to troubleshoot the situation on the latest versions.
Is it possible to prepare whole server backup\snapshot? If something goes wrong during the next test, you will be able to rollback entire server to current state.
The idea is Workspace updating to the latest versions via installation script: Installing server version from RPM/DEB packages using the provided script - ONLYOFFICE
You can find exact command for update process in the provided link.

The difference between your current and the latest versions is big, so you might face some issues. But I believe that this step probably can resolve the situation with Notify service, because some config files are overwritten during the update process.
Please note that I can recommend this step if you have the opportunity to create whole server snapshots\backups only.

Hello Alexandre,

The affected user has requested that the server be shut down rather than pursue further efforts to try and recover access.
Thanks for your help.

Understood, please feel free to contact us if you face any issues.