Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

How to improve docs saving speed?

Every time I save the document , the saving time is 5s or even 10s. I want to improve the speed of document saving, so I modified the local.json,

{
“services”: {
“CoAuthoring”: {
“server”: {
“savetimeoutdelay”: 500
}
}
}
}
Then restart the server.But every time after force-save or closing the document, it still has to wait 5-10s before the callback can receive a request from onlyoffice.So how can I improve docs saving speed correctly?
Document Server version:7.1.1
Type of installation of the Document Server (docker, deb/rpm, exe)
OS:windows server 2012
Browser version: chrome

Hello @lxm
You found right parameter - savetimeoutdelay. We have description about this parameter in these titles:
https://api.onlyoffice.com/editors/save#savedelay
Configuring ONLYOFFICE Docs Developer Edition - ONLYOFFICE (services.CoAuthoring.server.savetimeoutdelay)

Probably the issue that you have restarted whole server. If you’re doing to change default.json file, you have to restart all services via supervisorctl restart all command (Linux) or restart all Document server services in Windows Services.

By the way, please note that we do not recommend to set 0 as savetimeoutdelay value. Also, saving speed is related to a file structure itself. Different files can have different saving speed even if you have changed savetimeoutdelay value.