Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

How to enable https with private domain name in an inner network

I’m using a private domain name inside own company. The CA cert is self signed, and already added into the trust ca-certs in the docker. But when visiting onlyoffice with the domain name, documents can’t be open. Error window pops up with information “Download failed”.

I checked the log of /var/log/onlyoffice/documentserver/docservice/out.log. It says “Error: unable to verify the first certificate”. Seems the system trusted ca-certs can not take effects.

So how to enable https with private domain name in an inner network?

Document Server version:7.1.1
Type of installation of the Document Server : docker
OS: MacOS
Browser version: Chrome 103.0.5060.53

Hello @sunpj
I believe that the issue is related to your certificates. Usually I use this service to check out if there are any issues with certificates on a client server: SSL Checker
But it can help if a server has open access to the Internet.
Please run a test. Please open the config file /etc/onlyoffice/documentserver/default.json and change "rejectUnauthorized": true to false . Save the file and restart the services with command supervisorctl restart all
Please let me know if it helps.