How to change centimeters to points ?

I need to use points as the unit for line spacing,
How to change centimeters to points ?

1 Like

Hello @rokee

In File tab find Advanced Settings, then look for Unit of Measurement setting under Workspace section. You can switch units in dropdown menu to:

  • Centimenters
  • Points
  • Inches

Unit of Measurement setting is Global parameters , How to set “Line Spaceing” and “Indents” separately? In fact, I want to set the line spacing to points and Indents to characters like MS WORD.


It would be great to see a unit change for each setting, the thing is that the standardization documents at my college are written based on ms word, and indents are specified in centimeters and spacing in points, and it’s extremely inconvenient to have to go online every time to figure out the ratio of points to centimeters.

Hello @60d74 @rokee

If you insert a needed value in any unit that is different from Unit of Measurement setting, it will automatically converted in it. For instance, if you have Centimeters set up as main unit, then inserting value 20 pt will convert value to 0.7 cm.

Do I understand correctly that you want to let the editor display recently used unit without conversion to the default one from Unit of Measurement?

yes,I want to let the editor display recently used unit without conversion to the default one from Unit of Measurement

Hello again @rokee @60d74

We have registered an enhancement suggestion to add possibility to use needed units without conversion. This one will be implemented in one of the future releases of editors.

Thank you for your suggestion!

Hello @Constantine
In the Chinese environment, the system will not automatically convert the value I input to centimeters(such as 20 pt or 20 磅), regardless of whether the unit I input is Chinese or English

Can you record video demonstration of this behavior? By the way, let us know next items:

  • language of Desktop Editors used;
  • type and version of the OS where Desktop Editors are installed;
  • how Desktop Editors are installed (exe, msi, snap, etc.)


The Chinese word for centimeters is ’ 厘米’

  • language of Desktop Editors used; 【Simplified Chinese
  • type and version of the OS where Desktop Editors are installed; 【Red Hat Enterprise Linux release 8.2 (Ootpa) , onlyoffice 7.4.1-36 Community Edition
  • how Desktop Editors are installed (exe, msi, snap, etc.)
    I installed it using YUM according to official instructions
    URL: Installing ONLYOFFICE Docs for CentOS and derivatives - ONLYOFFICE

Hello @rokee
If you don’t mind, I will join this thread too.
In the provided video you’re trying to change used unit of measurement for line spacing, but this parameter is related to general setting of the file ( Advanced Settings > Unit of Measurement) as far as I know. So you have to change it there to use points or inches.
If I misunderstood the situation, please clarify it.

Hello @Alexandre
@Constantine told me that if I set the unit to centimeters in Advanced Settings > Unit of Measurement ,then entering 10pt in the line spacing setting input box will automatically convert to 0.376 centimeters. This is true in the English environment, but not in the simplified Chinese environment, regardless of whether I input 10pt or 10 磅 (The Chinese word for points is “磅”)
The following are two operating videos in different environments

Hello @rokee
Thank you for the provided video files. We are checking the situation. I will update this thread when we have something to share.


Hello @rokee
We have discovered a bug in the described scenario. We have started working on it. Thank you for pointing us to this situation.
@letgooo Please clarify your post, its purpose is not clear to me.

Hi @Alexandre @Constantine
Has this bug been fixed?

Hello @rokee
The bug with incorrect automatically conversion (pt to centimetres) will be fixed in the next version of Document server. We are planning to release it this winter.

Hello @rokee
We have just released Document server v.8.0. This release contains a fix for previously described issue.