Groups do not work when filling out oform

Do you want to: Suggest a feature / Report a bug / Ask a how-to question

Bug/Ask a how-to question

For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem.

I Created an oform from docxf file and created there 2 forms. 1 form can be filled only by users from group ‘Company’ and another field can only be filled by users from group ‘Client’. After that I opened created oform file in OnlyOffice document server and despite what group I specify I can change both fields. I use react library and my token is following:

  • eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJkb2N1bWVudCI6eyJrZXkiOiJPMnhORWxpY1ZUclJmLktqRVd6RiIsInVybCI6Imh0dHA6Ly9ob3N0LmRvY2tlci5pbnRlcm5hbDo3MDc5L2FwaS9SZXRyaWV2ZT9maWxlPWY1NmUzZDlmLWQxNTQtNGEyZC1hMjczLWY3YmU1ODI0ZWFlNl9sZXBwaW5nLm9mb3JtIiwiZmlsZVR5cGUiOiJvZm9ybSIsInRpdGxlIjoibGVwcGluZyIsInBlcm1pc3Npb25zIjp7ImZpbGxGb3JtcyI6dHJ1ZSwiZWRpdCI6ZmFsc2UsImVkaXRDb21tZW50QXV0aG9yT25seSI6ZmFsc2UsImNoYW5nZUhpc3RvcnkiOmZhbHNlLCJkZWxldGVDb21tZW50QXV0aG9yT25seSI6ZmFsc2UsImNoYXQiOmZhbHNlLCJjb21tZW50IjpmYWxzZSwiY29weSI6ZmFsc2UsIm1vZGlmeUNvbnRlbnRDb250cm9sIjpmYWxzZSwibW9kaWZ5RmlsdGVyIjpmYWxzZSwicHJpbnQiOmZhbHNlLCJwcm90ZWN0IjpmYWxzZSwiZG93bmxvYWQiOmZhbHNlLCJyZW5hbWUiOmZhbHNlLCJyZXZpZXciOmZhbHNlfX0sImVkaXRvckNvbmZpZyI6eyJtb2RlIjoiZWRpdCIsInVzZXIiOnsiZ3JvdXAiOiJDb21wYW55In19LCJkb2N1bWVudFR5cGUiOiJ3b3JkIiwibmJmIjoxNjg1NTIyNjgwLCJleHAiOjE2ODU2MDkwODAsImlhdCI6MTY4NTUyMjY4MH0.8noCaXBAxzV0NzCvbU7OIQcGpDWRBufWKufnIpFpQKg
    Decoded token
  "document": {
    "key": "O2xNElicVTrRf.KjEWzF",
    "url": "http://host.docker.internal:7079/api/Retrieve?file=f56e3d9f-d154-4a2d-a273-f7be5824eae6_lepping.oform",
    "fileType": "oform",
    "title": "lepping",
    "permissions": {
      "fillForms": true,
      "edit": false,
      "editCommentAuthorOnly": false,
      "changeHistory": false,
      "deleteCommentAuthorOnly": false,
      "chat": false,
      "comment": false,
      "copy": false,
      "modifyContentControl": false,
      "modifyFilter": false,
      "print": false,
      "protect": false,
      "download": false,
      "rename": false,
      "review": false
  "editorConfig": {
    "mode": "edit",
    "user": {
      "group": "Company"
  "documentType": "word",
  "nbf": 1685522680,
  "exp": 1685609080,
  "iat": 1685522680

Other than that my configuration is simple.

  • documentServerUrl is url of my OnlyOffice document server (this is correct as I can open oform)
  • token is token i pasted earlier
  • jwtConfig in decoded jwt tokens payload

My problem is that while my oform has 2 fields for 2 different groups the can be filled without being in any group or by being in only 1 group. Basically OnlyOffice behaves as if no group is specified and anyone can fill out anything. I would like to get behaviour when field can be filled only if user is part of certain group.
Also maybe important note that when I am edition docxf file and click on View Form for different type of groups it behaves as I would expect it to. Meaning that if I choose one group I can fill only fields associated with it.

Document Server version:


Type of installation of the Document Server (docker, deb/rpm, exe)



I am using Windows, but docker container is working on Linux

Browser version:

Microsoft Edge. Version 113.0.1774.57 (Official build) (64-bit)

Hello @raltvein
Unfortunately, there’s no way to achieve the desired scenario at the moment. As far as I understand, you’ve tried to achieve it via group permissions. But group permissions are being used for ‘comment’ and ‘review’ settings only.
Nevertheless, we’re planning to add OFORMS roles feature in the next version of Document server (v.7.4). I believe this feature will help you in your case.
Sorry for inconvenience.