Need dedicated support? Click here
Need dedicated support?
Click here

File conversion error -7

When I submit a request according to the documentation, I get an error -7. It is not clear from the logs what the problem is. When I look at the logs, the problem is in the outputtype, but I seem to be entering it correctly. Please help me figure out what the problem is.

Hi, @zvuk331
it looks like an error in the request body. (I don’t see any errors)

But, I see you are trying to use the URL of the document from the test example.
The test example is not intended to be used as a file storage

Please upload the file to some other storage and send another URL for the Document Server
For example, you can run your own: http-server - npm

Thank you for your answer. But, I have tried other links as well. For example: minio server (bucket is public)

Did the error stay the same?

-7 Input error

Yes, I tried in different ways

Need to clarify. Is the problem repeated on all files or only on one?
Can I ask you to provide a file on which the problem is reproduced?

Please specify according to which instructions you installed the document server and the version of document server.

The problem repeated on all files. I run onlyoffice using Docker.

I was able to reproduce this error.
The problem is in the correctness of sending the request.
-7 Input error

(Most likely one of the letters in the request was written in another language) Because the entire request is written correctly.

Try typing add the following request body:

    "async": false,
    "filetype": "docx",
    "outputtype": "pdf",
    "title": "test.doc",
    "url": ""

I tried but still error

Hi @zvuk331, please attach Document Server logs from /var/log/onlyoffice/documentserver/
after reproducing the issue.

Hi @Carl
Only this in the logs

Text: [2023-06-25T14:30:11.168] [WARN] nodeJS - convertRequest unexpected outputtype = : docId = convertRequest

Hey, @zvuk331
Does your document server have access to Internet?
Can we send a request to your server from our side?

I was able to reproduce this error when the “outputtype” field is incorrect. Like this:

Hello @Nikolas
I am aslo getting -7 error, because of outputtype, can you plz help to to hundle it?
and log is:
[2023-07-24T07:25:05.776] [WARN] [localhost] [conv_undefined_] [userId] nodeJS - convertRequest unexpected outputtype =
[2023-07-24T07:25:50.553] [WARN] [localhost] [conv_undefined_] [userId] nodeJS - convertRequest unexpected outputtype =
[2023-07-24T07:25:54.282] [WARN] [localhost] [conv_undefined_] [userId] nodeJS - convertRequest unexpected outputtype =

Hey @aigyr

I don’t know how you do it:)

How did you install the document server?
Let me try to install according to your scenario.

I am running document server in docker

and i can reach it from url localhost:8089
but i can’t use Conversation API correctly

in documentation says:

Sample of JSON object sent to document conversion service used to convert the file from docx format to pdf format

    "async": false,
    "filetype": "docx",
    "key": "Khirz6zTPdfd7",
    "outputtype": "pdf",
    "title": "Example Document Title.docx",
    "url": ""

Where is the name of the server where document manager and document storage service are installed. See the How it works section to find out more on Document Server service client-server interactions.

but i am not sure if in localhost:8089 has documentManager and documentStorageService

That’s right. The last paragraph: How it works

Please note, that ONLYOFFICE Document Server includes the document editor , document editing service , document command service , document conversion service and document builder service .

The document manager and document storage service are either included to Community Server or must be implemented by the software integrators which use ONLYOFFICE Document Server on their own server.

Can you write me via PM?


Can you send the local.json file from the docker container?

/etc/onlyoffice/documentserver/local.json (In container)

您好 @liyaxuan :wave:t3:

  1. 您在哪个系统安装ONLYOFFICE Document Server?
  2. 您安装类型是哪一个(exe, docker, deb/rpm)?
  3. 您使用的ONLYOFFICE Document Server版本是什么?
  4. 您安装时按照哪个教程安装?请把教程链接发给我
  1. 也是在centos7中用docker安装的
  2. docker
  3. 社区版
  4. docker-compose Running ONLYOFFICE Docs using Docker Compose - ONLYOFFICE