ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

File changes lost after onlyoffice 5.4.6 to 7.0.3 new server migration

Do you want to: Report a bug / Ask a how-to question

For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem:

Document Server version: 5.4.6 to 7.0.3 new server migration
Connector version: 6.4.2
DMS (platform) version:
OS: CentOS 7.9 to Ububtu 21 (new server)
Browser version: all main browsers latest version
Attach logs if possible.

Hi!

Not sure this is the bug.
Setup: Nextcloud v21 community with Onlyoffice 5.4.6 (Centos Virtual Machine)
I was unable to perform inplace upgrade on Centos so I installed new Ubuntu server and installed clean Onlyoffice installation.
I also upgraded integration connector.
Everything was fine, but today some users reported that they lost changes in their files and file version is pretty old 6-7 month ago.
I think that thay never pressed Save button and autosave option in connector was disabled by default. But I’m not sure about that. Nextcloud shows that file changed 7 month ago and all backups have the same old version of file.
Is there any way to restore file changes? Looks like they are on old Only office server but I don’t know how to get them.
I’ve tried to switch back to old connector and server but it didn’t help.
When I press the link it reports Cannot open file for a first time, and next time just opens old file,

Hello @apodosenin
Please go to your old Document server and check this folder: /var/lib/onlyoffice/documentserver/App_Data/cache/files/forgotten

Does it contain any files?

Also please provide us with whole Document server logs folder (from old installation). It’s located here: /var/log/onlyoffice/documentserver/

One more thing.

I was unable to perform inplace upgrade on Centos

What difficulties did you face?

HI!

Just want to thank you so much.
I found latest versions in /var/lib/onlyoffice/documentserver/App_Data/cache/files/forgotten

After upgrade of old server everything was looking good.
But when I tried to open file, I got “Download failed” error just like on ONLYOFFICE Api Documentation - Troubleshooting
And even Onlyoffice example didn’t work wtih “Document couldn’t be save” error.
Although the empty document was created susccessfully.
I didn’t investigate too much and just installed new server and it works nice.

Oh, that means the issue is solved?

Yes, thank you once again

Best regards, Alex

1 Like