ONLYOFFICE DocSpace released: improve document collaboration with offices, customers, and partners. Use it for free!
ONLYOFFICE DocSpace released

Extension error with the Android app

Device: OnePlus 3T
OS version: Android 11
App version: version 5.5.2
Mode: Connected to Nextcloud

I can’t open any xlsx/ods file. I always get an error saying that the file extension is incorrect.
if I create a new file I get the same error.

Thank you

Hello @upbeat

Please send us a video recording of the screen showing the problem you are facing to help us fully understand the situation. Also, could you please specify the version of Nextcloud you are using? Thank you.

Hello @Russell
Here is a video of the problem:
The Nextcloud version: 25.0.2
Thank you.

Would it be possible for you to share a Nextcloud account with us, so that we can investigate the matter in question more thoroughly? Having access to the account would allow us to get a better understanding of the situation.

Sorry I can’t. I’m a customer of a french association called Zaclys who hosts the Nextcloud server.

Understood. Could you please try checking the situation on another device, if you have one available? This might help us determine if the issue is specific to the device you are currently using or if it is a wider problem.

Interesting. It works on my tablet. It’s a Samsung tab running a Lineage GSI build for Android 12.
I can try recording a log on my phone. Would it help?


Try reinstalling the application and clearing its cache.

  • Tap the Clear cache option in the Common settings section,

  • Tap the Accept button in the confirmation window.

Here is the guide from ONLYOFFICE Help Center: ONLYOFFICE Documents for Android - Overview - ONLYOFFICE

Please, notify us of the results.

It didn’t help.

Hello @upbeat

Apologize for the late response. We have checked your situation on several devices running Android 11, but were unable to reproduce the issue. Could you please check if opening .xlsx files works in the mobile browser rather than the app?

Hello @Russell
No issue if I open my test.xlsx file with Firefox.

If it can help, here is a log when trying to open it from the app.

Hello @upbeat!

Apologize for the late response. At the moment, we are working on this situation and hope that the new version of OnlyOffice for Android will resolve this situation. We ask you to wait a bit and apologize for the inconvenience.

1 Like

Hello @Russell
Just to say that the problem is solved. Thank you!

1 Like